Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I've noticed since few days ago that same repeating kind of messages occurs and I positively can say that nothing was intentionally changed (installed/uninstalled) in that period.

here's sample of /var/log/kern.log message:

Mar 30 06:32:45 aurora kernel: [566322.867110] e1000e: eth0 NIC Link is Down

Mar 30 06:32:47 aurora kernel: [566325.313634] e1000e: eth0 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: Rx/Tx

Mar 30 06:32:59 aurora kernel: [566337.632930] e1000e: eth0 NIC Link is Down

Mar 30 06:33:18 aurora kernel: [566356.543664] e1000e: eth0 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: None

Mar 30 11:05:47 aurora kernel: [582689.779752] e1000e: eth0 NIC Link is Down

Mar 30 11:05:50 aurora kernel: [582692.174337] e1000e: eth0 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: Rx/Tx

from complete log file - when take all log message this kind into count - I can conclude:

  • eth0 fails every few hours
  • eth0 fails in first case for two and in second for 19 seconds

It's production server I'm talking about here.

How to solve this problem, since mail server is in production and network failures of 19 seconds duration I cannot tolerate?

share|improve this question
1  
What have you checked so far? Is the cable properly attached and in unharmed condition? Does the switch on the other end also observe the link going down? Worth noting is that the detected link is different at different times (flow control differs in your log). Maybe the autonegotiation fails? Does the problem go away if you force 1000Mbps FD Rx/Tx? –  Håkan Lindqvist Mar 30 '14 at 11:36
    
@HåkanLindqvist I don't have option to check cable, since server is not physically near me. Is that something I should ask server farm tech stuff to check? How do I force 1000Mbps FD Rx/Tx? And, about flow control being different at different times, is this issue? –  Miloshio Mar 30 '14 at 11:51
    
The link "type" changing over time suggests to me that something is not quite right but finding the actual cause is of course a separate question entirely. Asking the tech staff may be a good idea. –  Håkan Lindqvist Mar 30 '14 at 11:54
1  
You can use ethtool or mii-tool to check auto-negotiate status etc at the server end. You need to make sure that the switch your server is setup to match. This sounds like a hardware problem - could be server adapter, cable or switch. I suggest looking at the status of the switch to see what it thinks is happening. –  Paul Haldane Mar 30 '14 at 15:35

1 Answer 1

up vote 0 down vote accepted
  1. check for errors on the wire, look at the "errors" field in the output of ifconfig. If non-zero then there are problems with hardware (cable, NIC card, or hub/switch). An unreliable Ethernet cable will give errors in this field too.
  2. replace the Ethernet cable, regardless of step 1. This is quick, cheap and easy, and should be done whenever your link is going up and down at random intervals.
  3. use ethtool and make sure the network settings (duplex, etc) match those on the switch. If you are not the admin of the switch, then ask the network admin to provide you with the settings.
  4. if the switch has flow control enabled, then be sure it is enabled on your Linux box. Otherwise, disable it.

As a side note, you should assess whether you need flow control. According to HP, it is only necessary for high-performance applications: see HP article on When to Use Flow Control

share|improve this answer
    
It was wire errors. Server farm tech stuff did the job after I've reported errors. –  Miloshio Mar 19 at 8:53
    
'ifconfig' was showing errors? –  Michael Martinez Mar 19 at 17:29

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.