Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am working on an internal facing wiki that is hosted on a linux box in the office that also holds our backup-server roll. The name of this server is 'backup-server' and DNS resolves this to the correct IP (

I would like for the users accessing the wiki to be able to go to '' where the domain is our internal office domain. I thought this would be a simple DNS A record change but it seems to be not working as I thought it would.

The other way that i have made this work on the few computers I use while developing the wiki is to just edit the 'hosts' file with:

I have a Win Server 2012 DNS server and would like to edit the DNS there so that i can easily push out the change to all computers in the network but I cant seem to get this to work.

How would i go about getting this FQDN pointing to the correct IP?

share|improve this question

closed as off-topic by MichelZ, Jenny D, Ward, Nathan C, TheCleaner Apr 2 '14 at 3:10

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions must demonstrate a minimal understanding of the problem being solved. Try including attempted solutions, why they didn't work, and the expected results. See How can I ask better questions on Server Fault? for further guidance." – Jenny D, Ward, Nathan C, TheCleaner
If this question can be reworded to fit the rules in the help center, please edit the question.

I'm not familiar with Windows DNS Server, but every other DNS server on the market can have multiple names for any given ip address. Try just creating a new A record for and just ignore the existing backup-server DNS name. – Some Linux Nerd Mar 31 '14 at 21:26
You haven't actually told us what you did or what the result was. Did you add an A record for wiki to your internal DNS zone? Did you configure the appropriate host headers (or the equivalent) on the web server? – joeqwerty Apr 1 '14 at 3:53
This is what CNAME is for. – Jenny D Apr 1 '14 at 13:51
Solved the problem... I was adding the A record to the 'office' sub domain. So for instance I was trying to get to but i was setting the A record to – Atari911 Apr 1 '14 at 23:29
up vote 0 down vote accepted

Essentially what you need is a CNAME record that points to the backup server address.

That is presuming that when you try to resolve you get the 192 address.

Therefore, if your Win2012 server is the domain server for your then you can add the record in there, but I am thinking you more likely have another DNS that is handling the names for you and that is where you would need to add the address if you truly wanted

If you add a CNAME record into that DNS then it will most likely give an external address for your backup-server (if indeed it is visible in the primary domain).

share|improve this answer
I accepted this answer because this would be the way to do it. I was simply entering the records into the wrong sub-domain. – Atari911 Apr 1 '14 at 23:29

Not the answer you're looking for? Browse other questions tagged or ask your own question.