Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm trying to connect to a Windows Server 2012 R2 using RDP.

It works fine using the ethernet cable, but it gets stuck on "estimating connection quality" if I try to connect using WIFI. The WIFI router gives me access to the exact same network the cable does.

  • The server is hosted on Amazon.
  • I can connect to other internal servers and also on Azure VMs via RDP at the same client machine.

Any thoughts?

share|improve this question
    
Is the server connected via WiFi as well? –  EEAA Mar 31 at 21:29
    
Tks. The server is hosted on Amazon (I updated the question). –  Andre Carlucci Mar 31 at 21:37
3  
Set the connection quality manually. Problem solved. –  HopelessN00b Mar 31 at 21:45
    
@HopelessN00b I tried to do that in past, but it didn't work. After your comment, I came back, set the connection quality and also unchecked all visual options (desktop compostion, visual styes, etc). That did the trick. Please, put your comment as an answer so I can mark it as correct and you get the points. Thanks. –  Andre Carlucci Apr 2 at 12:35
    
@HopelessN00b Ohhhhh I'm so sorry! I was so eager to solve the problem that I tried your solution in the wrong server (internal IP 192.168.14.12 instead of 192.168.14.13). The problem still persists even setting everything manually :( –  Andre Carlucci Apr 2 at 12:57

1 Answer 1

If having Windows detect your connection quality is giving you grief, I would recommend working around the problem by setting it manually. (The Experience tab of the built-in Windows RDP client, mstsc.exe).

enter image description here

Once you've selected any of the other options, you can manually adjust the settings (by checking or unchecking the check boxes) to be whatever you wish.

share|improve this answer
    
Please, see my comment above. I'm so sorry to make you answer here. Any way, maybe this method could solve other people's problem, but unfortunately it didn't work for me. –  Andre Carlucci Apr 2 at 13:00

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.