Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

How can I make a number sign show up???

share|improve this question
    
What unix are you using? –  chris Aug 25 '09 at 18:35

4 Answers 4

There is the very remote possibility that the user is using an antique unix that has # mapped to delete and @ mapped to kill (^U on most traditional modern systems).

If his system is configured this way, he will not be able to type a # because every time he does it will delete whatever character is to the left of where he is trying to type the #. The simplest way to fix this is stty erase (ctrl-V)(backspace key).

This is unlikely to be the case -- it's not likely that anyone is running irix 5.4 or hp/ux 10.20 these days, but who knows, right?

share|improve this answer
    
and often users don't notice this because their system is using an old version of bash that ignores these stty settings; they won't notice their wacky stty settings until they run an app that doesn't override the settings (such as vi). –  chris Aug 25 '09 at 18:51
    
plus 1 for stirring up (useful) memories from the good ol' days... –  Jessica McKinnon Sep 8 '09 at 19:08

Assuming a US keyboard, Press i to go into insert mode, and then shift-3. You can use either shift key, and press it the same time as the '3' key. The three key is after two, and before four.

share|improve this answer
    
I am teasing a bit of course, are you just trying to edit a file? vi has to modes, command and input, press i to go into input mode, and esc to go back to command mode –  Kyle Brandt Aug 25 '09 at 17:55
    
Also, you might try a command like 'nano' for the time being to edit the file if it is installed. –  Kyle Brandt Aug 25 '09 at 17:57

If you're in insert mode, it should be just the same as any other application. If it doesn't say "--INSERT--" at the bottom of the terminal, hit i, then try typing. When you're done, hit escape to get out of insert mode and back to "command mode".

On the off chance you're using a Mac with a UK keyboard layout, you need to use alt+3 to get a # symbol.

share|improve this answer
1  
Sorry, I should have added.. the "--INSERT--" thing will only show up in vim, which substitutes vi on a lot of systems. The only way to know you're in insert mode in actual vi is if you can, well, insert stuff. –  Andrew Aug 25 '09 at 18:10

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.