Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I am trying to install Windows 2008 server on a HP Proliant DL180 G5. There is no built-in DVD reader so I need to use my LaCie USB one.

When I put the CD in and boot from the USB DVD on the server, I get the error message:

Boot Failed! Please insert boot media in selected boot device.

So I tried with another Windows bootable CD and still no luck.

What I've done then, I copied the installation DVD on my 16go USB key. Again, impossible to boot from the USB Key.

I have 2 147go SAS 15k HDD on my server. They are not showing in the Bios. I was wondering if this is a reason why nothing will boot on it.

I am trying to find a way to deploy Windows 2008 server on my HP server as soon as possible.

If you guys have ideas, feel free to let me know :)

Best regards, David.

System Information: HP Proliant DL180 G5 Quad-Core 2.5 4GO Ram 2x 147GO SAS 15k

P.S. This is my first installation ever on SAS/SCSI HDD.

Thanks a bunch!

Edit:

Well, my bad! I purchased a new USB DVD and now I can install Windows 2008 server.

Thanks a bunch for your help!

share|improve this question

5 Answers 5

up vote 0 down vote accepted

I suspect Mr. Denny's nailed it.

Also look for a bootup message about a boot menu (F12 is popular) to see if you can pop up a menu of available boot devices.

Not trying to be a jerk, but did you boot another computer from that DVD or USB to make sure it's happy? I only say this because I've spun my wheels in this manner a few times. ;)

share|improve this answer
    
When I insert the CD key in my laptop, a normal Windows XP SP3, the install prompt me to run the Install.exe or something so yes, it seems to work fine but I can install it from scratch on my server. I'm wondering if the SAS HDD are the problem. I don't see any SCSI/SAS controller in the BIOS and no HDD are found in there also. –  r0ca Aug 26 '09 at 13:57

You'll probably need to go into the BIOS and enable it to boot off the USB drive.

share|improve this answer
    
This has been done already. I can see the USB drive but unfortunately the NTFS format doesn't seems to be taken in consideration there... So Windows 2008 won't boot –  r0ca Aug 26 '09 at 13:45

Have you made your USB key bootable? I usually use mkbt. You'll also need to ensure the BIOS is set to allow boot from USB

share|improve this answer
    
Yes it's supposed to be bootabled but I'll give a try to mkbt. Keep you posted! Thanks! –  r0ca Aug 26 '09 at 15:11

You need to make the USB key bootable first.

You can do this by following these steps:
--please note that this process will format the USB key
1. Open a command prompt (an administrator command prompt if using Vista/Win7/Server 2008)
2. enter diskpart by typing in the following command: diskpart
3. find out which disk is the USB key by entering: list disk
4. note the disk number of the USB key (we'll use [diskNumber] as a placeholder in the next step)
5. select disk [diskNumber]
6. clean
7. create partition primary
8. select partition 1
9. active
10. format fs=fat32
11. assign
12. exit

Copy the files from the installation media to the USB key and you should be good to go.

share|improve this answer
    
I tried it also but the USB key was considered as a volume instead as a Disk... –  r0ca Aug 26 '09 at 13:51

When you boot from the USB drive does it say no boot media. What software are you using to create the DVD image installed on the USB drive ?.

This might help

  1. Set BIOS to boot from removable media ie: USB drive.
  2. Create an ISO of the DVD/CD with a tool like InfraRecorder using the Read Disc feature.
  3. Reformat the USB drive, better be safe than sorry.
  4. Then use a tool like Unetbootin to install the ISO image you created with InfraRecoder on the USB key. And reboot.
share|improve this answer
    
I used HP Tool to create the bootable so it started MS-DOS 98 but the setup (W2008) doesn't run on DOS... I performed a NTFS format on the USB to make sure NTFS file were copied onto it but no luck again. –  r0ca Aug 26 '09 at 13:54

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.