Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm trying to preseed a debian wheezy box using a USB drive. I've done preseeding in the past using a webserver, but am stuck trying to use USB. I get to a red screen that reads

[!!] Load debconfpreconfiguration file
Failed to retrieve the preconfiguration file. The file needed for preconfiguration could not be retrieved from the file:///hd-media/preseed.cfg. The installation will proceed in non-automated mode.

It would appear that my pressed.cfg is not loading...some background.
1) I used "unetbootin" to create a bootable usb (is this the problem? I tried the "dd if=/.." approach but it made the device read only....). Does this approach give me the wrong syslinux.cfg to start with or something along those lines?

2) I modified the sys.cfg...here's an abbreviated view including the option I'm trying.
default menu.c32
prompt 0
menu title UNetbootin
timeout 100

label WheezyTry
menu label ^Automatic Install Squeeze
kernel /install.386/vmlinuz
append cdrom-detect/try-usb=true preseed/file=/hd-media/preseed locale=en_US console-keymaps-at/keymap=us languagechooser/language-name=English countrychooser/shortlist=US vga=normal initrd=/install.386/initrd.gz --

3) I've tried various preseed files, but my take is none of them are getting loaded. I can post my preseed file if that would help. I get a menu, select the option, get a bunch of white writing, get asked to to select keyboard, see message that CD-ROM is being scanned, and then get red screen.

Any suggestions appreciated!

UPDATE Have continued to try various syntax in the syslinux.cfg with no joy, including using "./" before the preseed.cfg (e.g. file:/hd-media/./preseed.cfg"). Has anyone gotten preseeding to work with Wheezy?

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.