Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I'm sorry for my bad English. After upgrading MySQL up to 5.6.17 version it's not working. I'm using Windows 7 as my server's operating system. Here is the my.ini and error log:

[mysqld]
basedir=C:\_server\_release\_backend\Mysql\
datadir=C:\_server\_release\_backend\Mysql\data\
port =3306
back_log = 50
flush_time=0
max_connections = 30
max_connect_errors = 10
open_files_limit=4110
key_buffer_size = 25M
read_buffer_size=2M
read_rnd_buffer_size=4M
join_buffer_size = 1M
sort_buffer_size = 1M
bulk_insert_buffer_size = 2M
max_allowed_packet = 2M
max_heap_table_size = 25M
max_sort_length = 20
max_tmp_tables = 25
table_open_cache = 400
table_definition_cache = 400
tmp_table_size = 25M
wait_timeout=60
interactive_timeout=30
ft_min_word_len=4
thread_cache_size = 4
thread_concurrency = 4
connect_timeout = 5
query_cache_type=1
query_cache_size=25M
query_cache_limit = 256K
myisam_max_sort_file_size = 256M
myisam_repair_threads = 1
myisam-recover-options=backup,force
transaction-isolation = READ-COMMITTED
lower_case_table_names = 2
#innodb_force_recovery=6
innodb_file_per_table = 1
innodb_file_format = barracuda
innodb_buffer_pool_size=256M

[mysqldump]
quick
max_allowed_packet =16M

[mysql]
no-auto-rehash
# Remove the next comment character if you are not familiar with SQL
#safe-updates

[isamchk]
key_buffer =20M
sort_buffer_size =20M
read_buffer =2M
write_buffer =2M

[myisamchk]
key_buffer =20M
sort_buffer_size =20M
read_buffer =2M
write_buffer =2M

[mysqlhotcopy]
interactive-timeout



2014-04-03 23:21:51 7788 [Note] Plugin 'FEDERATED' is disabled.
2014-04-03 23:21:51 7788 [Note] InnoDB: The InnoDB memory heap is disabled
2014-04-03 23:21:51 7788 [Note] InnoDB: Mutexes and rw_locks use Windows interlocked functions
2014-04-03 23:21:51 7788 [Note] InnoDB: Compressed tables use zlib 1.2.3
2014-04-03 23:21:51 7788 [Note] InnoDB: Not using CPU crc32 instructions
2014-04-03 23:21:51 7788 [Note] InnoDB: Initializing buffer pool, size = 256.0M
2014-04-03 23:21:51 7788 [Note] InnoDB: Completed initialization of buffer pool
2014-04-03 23:21:51 7788 [Note] InnoDB: Highest supported file format is Barracuda.
2014-04-03 23:21:51 7788 [Note] InnoDB: 128 rollback segment(s) are active.
2014-04-03 23:21:51 7788 [Note] InnoDB: Waiting for purge to start
2014-04-03 23:21:51 7788 [Note] InnoDB: 5.6.15 started; log sequence number 1600339
2014-04-03 23:21:51 7788 [ERROR] Aborting

I can't disable InnoDB data storage, because I want to use it in future. Currently no tables using this storage. I hope you can help me. Thanks for advance.

share|improve this question

1 Answer 1

If you have no data in InnoDB, try deleting the InnoDB log files ib_logfile0 and ib_logfile1. The error log entry indicates that these somehow cause the problem.

share|improve this answer
    
I tried to do it over 100 times - no result. –  SIOIV Admin Apr 3 '14 at 20:15

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.