Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Since APC is not supported by PHP 5.5 as an OP code cache I read that I can still use APC for user data which sounds good for me. It's called APCu and it should be compatible with the old APC.

Unfortunatelly, I'm not able to install it in any way. Running:

apt-get install php5-apcu

will end wit error message:

The following packages have unmet dependencies:
 php5-apcu : Depends: phpapi-20100525
             Depends: php5-common (= 5.4.26-1~dotdeb.0) but 5.5.10+dfsg-1 is to be installed
E: Broken packages

I thought maybe I can install it via PECL, but throws error during compilation:

/tmp/pear/temp/apcu/apc_cache.c:359: error: '}' expected (got ",")
make: *** [apc_cache.lo] Error 1
ERROR: `make' failed

Have anyone managed to install APCu?

share|improve this question

It seems that you are using the repository for your old PHP, and some other repository for PHP 5.5. The other repository doesn't have php5-apcu package available, therefore it tries to use PHP 5.4 package for it.

The solution is to use's PHP 5.5 repository to install your PHP 5. This repository should also contain the php5-apcu package you want. To install's PHP 5 repository, add these two lines to your /etc/apt/sources.list:

deb wheezy-php55 all
deb-src wheezy-php55 all
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.