Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've been trying to test PowerShell Desired State configuration on a Windows Server 2012 instance on Amazon EC2. I downloaded the Windows Management Framework 4.0 from the MS download center:

Windows Management Framework 4.0

http://www.microsoft.com/en-au/download/details.aspx?id=40855

When attempting to install, I encoutered the following error:

Windows update could not be installed because of error 2148098050 "The certificate for the signer of the message is invalid or not found." (Command line: ""C:\Windows\system32\wusa.exe" "C:\Users\Administrator\Downloads\Windows6.1-KB2819745-x64-MultiPkg.msu" ")

Code signed installers normally include the certificate as part of the binary. I just right-clicked on the package and extracted the certificate manually from the MSU and installed it in the local machine certificate store to ensure the signer was trusted. When I tried to install the package again, I received a new error:

Windows update could not be installed because of error 2148073480 "Invalid algorithm specified." (Command line: ""C:\Windows\system32\wusa.exe" "C:\Users\Administrator\Downloads\Windows6.1-KB2819745-x64-MultiPkg.msu" ")

Can any one please help with resolving the above issue ?

share|improve this question
add comment

1 Answer 1

up vote 2 down vote accepted

I was downloading the wrong file. The correct file for Server 2012 was the following (from the same link posted in the question):

Windows8-RT-KB2799888-x64.msu

Installing the MSU above worked flawlessly.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.