Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

For several months we encounter problems delays :

we have a server ( os: ubuntu server 12.04 ) with samba and ldap service . Our clients are on Mac, Windows and Linux client ubuntu . Huwaei NAS volumes are on NFS server

Some users copy large files ( from 1 GB to 10 GB) of their position on NFS volumes. When copying the flow is very slow and windows explorer will crash. MAC subfolders will take some time to appear and we also find delays . For a copy of files 1 or 4 GB can take an hour . In contrast files less than 1 G0 is fast enough.

I think samba over NFS application optimization , know if there is a way to optimize the speed by putting a particular command line in smb.conf ?

But if we go on CIFS ( on Windows workstations) flows are very fast ( 70 MB / s to 95 MB / s constant !)

So we can consider that CIFS is optimized for Windows. NFS client on MAC and Linux is not very optimized default

Best regards

share|improve this question
    
Have you tried adjusting the "max xmit" parameter in your smb.conf? Also, can you post the results of running "testparm -v"? Make sure to edit out any sensitive information. –  Eirik Toft Apr 7 '14 at 19:48
    
Load smb config files from / etc / samba / smb.conf rlimit_max: Increasing rlimit_max (1024) to minimum Windows limit (16384) WARNING: The "share modes" option is deprecated Processing section "[Homes]" Processing section "[Atlantis]" Processing section "[data-dc]" Processing section "[videos_OLD]" Processing section "[laboratory]" Loaded services file OK. WARNING: You Have Some That Are share names along than 12 characters. These May not be available to Some older clients. (Eg. Windows9x, WindowsMe, and smbclient prior to Samba 3.0.) Server role: ROLE_STANDALONE –  user201680 Apr 8 '14 at 13:06
    
The -v when added should show all of the current smb settings. That being said, try adding "* - nofile 16384" to your /etc/security/limits.conf file and reboot. –  Eirik Toft Apr 8 '14 at 17:32

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.