Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm trying to backport a package, but dget (dscverify) says that it can't check the signature because of public key not being found:

[root ~/build/openssl] dget -x http://ftp.de.debian.org/debian/pool/main/o/openssl/openssl_0[72/753]
queeze14.dsc
dget: retrieving http://ftp.de.debian.org/debian/pool/main/o/openssl/openssl_0.9.8o-4squeeze14.dsc
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100  2003  100  2003    0     0  27106      0 --:--:-- --:--:-- --:--:-- 47690
dget: retrieving http://ftp.de.debian.org/debian/pool/main/o/openssl/openssl_0.9.8o.orig.tar.gz
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100 3684k  100 3684k    0     0  3507k      0  0:00:01  0:00:01 --:--:-- 3615k
dget: retrieving http://ftp.de.debian.org/debian/pool/main/o/openssl/openssl_0.9.8o-4squeeze14.debia
n.tar.gz
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100 94425  100 94425    0     0   371k      0 --:--:-- --:--:-- --:--:--  422k
openssl_0.9.8o-4squeeze14.dsc:
dscverify: openssl_0.9.8o-4squeeze14.dsc failed signature check:
gpg: keyblock resource `/root/.gnupg/secring.gpg': file open error
gpg: Signature made Mon 11 Feb 2013 11:04:16 PM EET using RSA key ID 1A5522DD
gpg: Can't check signature: public key not found
Validation FAILED!!

I've tried updating debian-keyring package, specifying dsc files from different versions of debian. To no avail. How come it can't verify the signature? Can I ignore this messege? Or what an I to do?

share|improve this question
1  
Stop using lenny? That went out of support years ago. –  Michael Hampton Apr 8 at 13:45
    
It's not lenny, it's squeeze. –  x-yuri Apr 8 at 13:49
    
Do you have the debian-keyring package installed? –  Nathan C Apr 8 at 13:57
    
Yes, I stated the in the question. But I've confirmed that just now, dpkg says 2010.12.29 for version. –  x-yuri Apr 8 at 14:06
    
The same goes for wheeze. –  x-yuri Apr 8 at 14:40

1 Answer 1

up vote 0 down vote accepted

Running the following command solves the problem.

$ gpg -k

As far as I can tell, the problem lies in gpg complaining about not being configured. In the end the following command is run:

cat openssl_0.9.8o-4squeeze14.dsc | gpg --batch --no-options --no-default-keyring \
    --always-trust --keyring /usr/share/keyrings/debian-keyring.gpg \
    --keyring /usr/share/keyrings/debian-maintainers.gpg

UPD And here's a bug report.

UPD Link to mailing list discussion.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.