Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

From my server, connecting to it via eth0 (not localhost), I can connect via SFTP:

Apr  9 10:02:40 domain sshd[11526]:
  Accepted password for test from 1.x.x.x port 45335 ssh2

From a remote Filezilla, I cannot connect using the same password:

Apr  9 10:04:25 domain sshd[11531]:
  Failed password for test from 2.x.x.x port 26714 ssh2

Both IP addresses are in hosts.allow and the SSH config is properly and setup to allow special ssh and sftp groups to connect.

What could be the error?

share|improve this question

1 Answer 1

I was able to fix this and the answer is so nifty, I thought instead of discarding the question, I'm sharing the solution:

When I connected to my server using putty and root to set a new password for test, the putty session used ISO-8859-1:1998 (Latin-1, West Europe) encoding. I've put an umlaut in the password which is multibyte in UTF-8, so I had to change the putty session encoding to UTF-8 and change the password again.

I was pretty sure my config is good so I came to this by accident....

Always remember when setting passwords through putty:

ISO täst != UTF-8 täst

enter image description here

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.