Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm hoping someone can help identify a problem or at least send me in the right direction.

I've created an NFS share on FreeNAS. The server has an external IP. I can mount this on my Debian machine (which is on the local network) with:

mount -t nfs 1.2.3.4:/mnt/backup /mnt/backup

I can't mount this from any VM on my XenServer machine or on Dom0. I've exhausted my Google searching abilities. The following is the command I am running and the verbose return. I appreciate any help! Thank you

mount -v -t nfs -o tcp 1.1.1.1:/mnt/backup /mnt/backup

mount.nfs: timeout set for Sat Apr 12 16:51:43 2014
mount.nfs: trying text-based options 'tcp,vers=4,addr=1.1.1.1,clientaddr=2.2.2.2'
mount.nfs: mount(2): Protocol not supported
mount.nfs: trying text-based options 'tcp,addr=1.1.1.1'
mount.nfs: prog 100003, trying vers=3, prot=6
mount.nfs: trying 1.1.1.1 prog 100003 vers 3 prot TCP port 2049
mount.nfs: prog 100005, trying vers=3, prot=6
mount.nfs: trying 1.1.1.1 prog 100005 vers 3 prot TCP port 790
mount.nfs: portmap query failed: RPC: Remote system error - Connection timed out
mount.nfs: trying text-based options 'tcp,vers=4,addr=1.1.1.1,clientaddr=2.2.2.2
share|improve this question
    
What if you remove -o tcp from your mount command ? Also, is your FreeNAS server ip 1.1.1.1 or 1.2.3.4 ? –  krisFR Apr 12 at 16:52
    
FreeNAS IP is 1.1.1.1 (well, not really obviously!). I'd read that XenServer requires TCP NFS connection but removing -o tcp gives: mount.nfs: timeout set for Sat Apr 12 17:49:39 2014 mount.nfs: trying text-based options 'vers=4,addr=1.1.1.1,clientaddr=2.2.2.2' mount.nfs: mount(2): Connection timed out mount.nfs: Connection timed out –  Paul Whalley Apr 12 at 16:54
    
Are you able to ping your FreeNAS IP from your XenServer machine ? –  krisFR Apr 12 at 16:58
    
Yes I can ping the server. RPCINFO gives this though: rpcinfo -t 1.1.1.1 nfs rpcinfo: RPC: Remote system error - Connection timed out program 100003 is not available –  Paul Whalley Apr 12 at 17:12
    
I don't use FreeNAS, so i talk blindly. From the doc rpcbind uses TCP/UDP 111 and nfsd uses TCP 2049. Are you able to telnet 1.1.1.1 111 and telnet 1.1.1.1 2049 ? If not, also check this from your working Debian machine and compare. You could also compare a tcpdump trace from the working and from the non-working machine (I am thinking about filters on the way (iptables/Firewall) –  krisFR Apr 12 at 17:16

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.