Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a problem with my Ubuntu server. I start a new remote ssh session (from windows putty or ubuntu client) to my server. After a while (I think it is when I hide the console window), my input is not shown in the console. But when I type for example "ls", I get the listing.

This means that the input was sended, but I don't see it. I can only close the console and start a new ssh session. But the next annoying point is, that when I start a new screen and I have this problem there, it don't go away after reconnecting. I have to restart the screen bash.

Does anyone have an idea whats going wrong? It seems that it is a problem on the server, because I tried with windows and linux with the same result.

thanks plucked

share|improve this question
up vote 13 down vote accepted

This can happen after a program dies leaving a terminal in an abnormal state. To fix it temporary you "reset" the terminal with:

$ reset
share|improve this answer
My Hero! It works. Thanks. – plucked Aug 26 '09 at 11:29
Happy to help :) – rkthkr Aug 26 '09 at 15:27
In the rare cases where the icrnl line setting has been disabled, it is advisable to type Control-J reset Control-J. (you can ignore the spaces). Return typically sends CR, which is converted to NL on input if icrnl is enabled. If it's not, then typing something and pressing Return does not send the command to the shell. – ΤΖΩΤΖΙΟΥ Oct 30 '09 at 1:08

While @rkthkr's answer worked for me, it has the unfortunate side-effect of changing my terminal window dimensions from what they were - which in some cases, I suppose this may also have been corrupted and also in need of a reset.

With this in mind, I'm using:

$ stty sane

From man stty:

   sane   same as cread -ignbrk brkint -inlcr -igncr icrnl  -iutf8  -ixoff
          -iuclc  -ixany  imaxbel opost -olcuc -ocrnl onlcr -onocr -onlret
          -ofill -ofdel nl0 cr0 tab0 bs0 vt0 ff0 isig icanon  iexten  echo
          echoe  echok  -echonl  -noflsh  -xcase  -tostop -echoprt echoctl
          echoke, all special characters to their default values

In my particular case, using pv -c (pipe viewer) consistently caused my input to go hidden. For now, I've actually scripted a stty sane command after my command that uses pv -c to ensure that my terminal remains functional.

share|improve this answer

When you can't see the command that you are typing, can you see the prompt and the cursor?

If not, the next time that happens, try the clear command, then try typing something and see if you can see it.

If this helps, then it probably means that your prompt is hidden below the bottom of the window for some reason. Either resize the window or scroll back down (you may have scrolled up in the window buffer somehow).

share|improve this answer
I don't see the cursor and clear doesn't help )o: – plucked Aug 26 '09 at 11:28
Do you see the prompt? Did clear clear the screen? – Dennis Williamson Aug 26 '09 at 12:56

If reset fixes your problem, then you probally are running an application which messes with your terminal settings.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.