Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am trying to install istSOS following these instructions from the website:


Installation

Install PostgreSQL

$ sudo apt-get install postgresql postgresql-client postgresql-contrib pgadmin3

Install PostGIS

$ sudo apt-get install postgresql-9.1-postgis

Configure PostgreSQL password

$ sudo -u postgres psql
> alter user postgres password 'postgres';

Install Apache2

$ sudo apt-get install apache2

Install mod_wsgi

$ sudo apt-get install libapache2-mod-wsgi

Install psycopg2

$ sudo apt-get install python-psycopg2

Download istSOS and unpack it in /usr/local/istsos

$ wget http://istsos.googlecode.com/files/istSOS-2.0.tar.gz

The download location actually has changed to SourceForge.

$ sudo tar -zxvf istSOS-2.0.tar.gz  -C /usr/local/

Set executing permission and owner for the folders services and logs

$ sudo chmod 755 -R /usr/local/istsos
$ sudo chown -R www-data:www-data /usr/local/istsos/services
$ sudo chown -R www-data:www-data /usr/local/istsos/logs

Configure Apache and WSGI

  • Open /etc/apache2/sites-enabled/000-default.conf and add the following lines just before the tag </VirtualHost>

    WSGIScriptAlias /istsos /usr/local/istsos/application.py
    Alias /istsos/admin /usr/local/istsos/interface
    

Restart apache2 server

$ sudo /etc/init.d/apache2 restart

Check the installation success on the browser loading the page

http://localhost/istsos/admin

Problem

However, the webserver returns Unable to connect.
When I try http://localhost:8080/istsos/admin instead I receive:

Not Found
The requested URL /istsos/admin was not found on this server.

Searching for an answer

As suggested by krisfr I try to find out why the server responds on port 8080 instead of port 80.

$ apache2ctl -t -D DUMP_VHOSTS
VirtualHost configuration:
*:80                is a NameVirtualHost
      default server localhost (/etc/apache2/sites-enabled/000-default.conf:1)
      port 80 namevhost localhost (/etc/apache2/sites-enabled/000-default.conf:1)
      port 80 namevhost localhost (/etc/apache2/sites-enabled/000-default.conf:1)

There seems to be no configuration for this?!


Update

I extracted the Apache/Port problem into another question and received a helpful answer. Then I configured the server to listen to port 80 and restarted the server. When I access http://localhost/istsos/admin I receive the following message:

Forbidden

You don't have permission to access /istsos/admin on this server.
Apache/2.4.6 (Ubuntu) Server at localhost Port 80

The owner settings for the folders are set as the instructions tell. I found alternative installation instructions for istSOS which I still have to understand but I already want to share with you.


Tutorial moved!

There is a new page for the tutorial!

share|improve this question
add comment

3 Answers 3

Any reason why you want to access istsos admin page on port 8080 ? I cannot see any reference to this port in the doc you provided.

In the doc they say to modify file /etc/apache2/sites-enabled/000-default.conf. This file is the default Virtual Host configuration for Apache. It is configured on port 80.

From now, it seems you already have a Virtual Host setup to listen on port 8080. So, open the configuration file for this Virtual Host and do the same you have done for the default one :

add the following before the tag </VirtualHost> :

WSGIScriptAlias /istsos /usr/local/istsos/application.py
Alias /istsos/admin /usr/local/istsos/interface
share|improve this answer
    
Where can I find the "the configuration file for this Virtual Host"? –  JJD Apr 14 at 15:22
1  
@JJD You should know that, are you the Web Server admin ? Try apache2ctl -t -D DUMP_VHOSTS to find some clues about where port 8080 is defined. –  krisFR Apr 14 at 15:41
    
It is my machine. Nonetheless, I do not understand why it responds to port 8080 instead of port 80. I posted the result of the command at the end of the question. –  JJD Apr 15 at 13:03
1  
@JJD What is the result for netstat -anp | grep :8080 ? –  krisFR Apr 15 at 13:06
    
tcp6 0 0 :::8080 :::* LISTEN 1804/apache2 tcp6 0 0 127.0.0.1:8080 127.0.0.1:45608 TIME_WAIT - –  JJD Apr 16 at 7:54
add comment

Try adding the trail / at the end of interface. the 8080 is actually the wsgi app(application.py) and 80 is frontend in apache for it.

share|improve this answer
    
Can you please update your post an give an example configuration? –  JJD May 6 at 20:04
add comment
up vote 0 down vote accepted

Finally, I got the server running after posting the problem to the istSOS mailing list. Here is the essential part of the answer by Milan:

This version of Ubuntu [13.10] comes with a newer version of Apache. In my case I solve the issue configuring Apache and WSGI in the following way:

I post the whole configuration file so it easier to understand. Here is the content of /etc/apache2/sites-enabled/000-default.conf on my machine:

<VirtualHost *:80>
    ServerAdmin webmaster@localhost
    DocumentRoot /var/www    
    ErrorLog ${APACHE_LOG_DIR}/error.log
    CustomLog ${APACHE_LOG_DIR}/access.log combined

    WSGIScriptAlias /istsos /usr/local/istsos/application.py
    Alias /istsos/admin /usr/local/istsos/interface
    <LocationMatch /istsos>
        Options +Indexes +FollowSymLinks +MultiViews
        AllowOverride all
        Require all granted
    </LocationMatch>
</VirtualHost>

Please remember to restart Apache after the configuration change:

$ sudo service apache2 restart
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.