Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have a machine running CentOS 5.8. IPv6 was disabled by creating a file /etc/modprobe.d/disable-ipv6 with the following contents:

options ipv6 disable=1

Removing the file and rebooting the machine should re-enable IPv6. Is there a way to enable IPv6 without having to reboot?


Additional info:

I found something that said to echo 0 > /proc/sys/net/ipv6/conf/interface/disable_ipv6, but /proc/sys/net/ipv6 does not exist on this machine.

sysctl shows nothing about IPv6:

# sysctl -a | grep -i ipv6 | wc -l
0

The ipv6 kernel module is loaded:

#lsmod | grep ipv6
ipv6                  437857  1 cnic

Attempting to remove it throws an error:

# modprobe -vnr ipv6
FATAL: Module ipv6 is in use.

# modprobe --show-depends ipv6
insmod /lib/modules/2.6.18-308.13.1.el5/kernel/crypto/crypto_api.ko 
insmod /lib/modules/2.6.18-308.13.1.el5/kernel/net/xfrm/xfrm_nalgo.ko 
insmod /lib/modules/2.6.18-308.13.1.el5/kernel/net/ipv6/ipv6.ko

Modprobe says crypto_api depends on the ipv6 module. Unloading and loading that on a running webserver does not sound like best idea.

I tried rmmod as suggested by @Zoredache:

# rmmod -v ipv6
ERROR: Module ipv6 is in use by cnic
share|improve this question
2  
Try rmmod ipv6, and then try re-inserting it? –  Zoredache Apr 14 at 16:19
    
@Zoredache Tried it, same results as modprobe -r (module in use). I could probably force it with -f, but at that point I'd rather just go the "clean" way and reboot the machine. –  hcsteve Apr 14 at 17:08
1  
Looks like you're going to have to reboot. –  Michael Hampton Apr 14 at 18:04

1 Answer 1

Looks like it's not possible. I ended up rebooting the machine to enable IPv6. I'd love for someone to prove me wrong since I have a slew of other machines configured the same way.

share|improve this answer
3  
For future readers: This is one of many reasons that we advise not disabling IPv6 even if you aren't yet deploying it. –  Michael Hampton Apr 15 at 21:47

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.