Sign up ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have a MAAS installation with it's interface at It is responsible for DHCP/DNS and the configurations are as follows: ip: subnet mask: broadcast ip: router ip: ip range low: ip rane high:

I am booting virtualbox machines on the same machine as the cluster controller/region controller, and they enlist fine. I change their name in MAAS, accept, and commission them. The enlistment and commission process take a very long time (just food for thought). Once the machine has been commissioned, (it says ready in MAAS nodes list). Run JuJu bootstrap. Juju has the following environments.yaml:

        type: maas
        maas-server: ''
        maas-oauth: pVreWZYhzaAFmqNjV3:W96PuEtANsr3n2SkGR:xF8dccH7NPUjhpejauzek$
        admin-secret: 'whatever'
        default-series: precise
        #authorized-keys-path: ~/.ssh/

when I run juju bootstrap, then power on the virtualbox VM, I get this:

picked arbitrary tools &{"1.18.1-precise-amd64" "   precise-amd64.tgz" "65ea92cd8812bff3e49df78f9e8e964e91c44af0abd49d880c4333a78c8abfda" %!q(int64=5368375)} - /MAAS/api/1.0/nodes/node-f942c69e-c400-11e3-bc28-0025906c5dd6/
Waiting for address
 Attempting to connect to test.draco:22

This screen will hang out for 10 minutes, and then I recieve the following:

 ERROR juju.provider.common bootstrap.go:123 bootstrap failed: waited for 10m0s without being able to connect: ssh: connect to host test.draco port 22: Connection refused

if I run a juju status while it is attempting to bootstrap, I get the following:

ERROR state/api: websocket.Dial wss://nova1.draco:17070/: dial tcp connection refused

over and over again.

I am using the 12.04.4 MAAS ubuntu install, and Juju version: 1.18.1-precise-amd64

The ssh keys have been generated, uploaded to maas, re-generated and uploaded to MAAS again. Also, the machine that juju is supposed to build will finish building (status in MAAS changes to "Allocated to bla") despite the environment bootstrap failure, and then it will power off. The status in MAAS goes back to "ready" and if I turn the virtual machine back on, it seems to go back into enlisting.

Anyone know what could be going wrong?

share|improve this question

1 Answer 1

up vote 0 down vote accepted

Running a juju status -e maas could give a better insight just in case. It seems to me that ssh is working as a but the host refuses connection, by this line:

 ssh: connect to host test.draco port 22: Connection refused

Are you aware that

#authorized-keys-path: ~/.ssh/

is actually commented out? You ought to uncomment the path to SSH keys, and if the problem persists you could check the file permissions for ssh keys. Hope it helps.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.