Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have configured some reverse proxies in order to map some HTTP audio streams that are normally accessed via different port numbers (e.g. http://fooserver:18030), to URL addresses accessible on standard port 80 (e.g. http://fooserver/capitalRadio).

It is working fine, but I have a problem. It seems there is some heavy buffering being done on the server. It takes around 5 minutes for the stream to start playing on the client.

Having no prior experience with URL rewriting on IIS, can someone point me out which setting(s) I can throttle back to reduce the playing delay?

share|improve this question

1 Answer 1

up vote 1 down vote accepted
+100

dont have a machine running IIS ARR infront of me at the moment, but found the following:

Server Farms > FarmName > Proxy > Buffer section > Response Buffer Threshold

Via here. Hope this helps...

share|improve this answer
    
@TiermanO, thanks for responding. When I set up the reverse proxy, I did it at the directory level (I created a normal directory under ´inetpub/wwwroot´ and then added a ´web.config´ file with the URL Rewrite rule), unfortunately I don't have anything under Server Farms (the list is empty) Do you recommend that I create one even though just a single server will be responding to client requests? Thanks again. –  sgorozco Apr 22 at 15:08
    
I think arr is the newer version of redirection... It has some extra features... It maybe your best bet to install and confirm that... Even if you only have a single box... –  TiernanO Apr 22 at 15:09
    
@TiermanO, thank you, it was not necessary to create a Server Farm, the Application Request Routing feature has a Server Proxy Settings section with Response buffer size and Response buffer threshold settings. I set the values to 256 and 8 KB respectively and it solved the problem. I'm not allowed yet to grant you the bounty, I must wait 13 hours more, but thanks for pointing me to the solution. –  sgorozco Apr 23 at 0:31
    
No problem. Glad to help! –  TiernanO Apr 23 at 5:35

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.