Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I am using CentOS 6.5 64

using this script to install xen on server

yum install http://fedora.cu.be/epel/6/x86_64/epel-release-6-8.noarch.rpm
yum install centos-release-xen
yum install xen
/usr/bin/grub-bootxen.sh
reboot

Bridging

[root@CentOS ~]# brctl show bridge name bridge id STP enabled interfaces xenbr0 8000.08002754b3fa no eth0

I tried to create new virtual machine using xm command

Xen configuration file

kernel = "/var/lib/xen/images/vmlinuz" ramdisk = "/var/lib/xen/images/initrd.img" extra = "text ks=http://192.168.1.8/kickstart-minimal6-x86_64.cfg" name = "xc63" memory = "512" disk = [ "file:/var/lib/xen/images/centos63.img,xvda,w","file:/var/lib/xen/images/centos63.swp,xvdb,w" ] vif = [ 'bridge=xenbr0' ] vcpus = 1 on_reboot = "destroy" on_crash = "destroy"

when start creating I am getting this error

[root@CentOS images]# xm create xen_1 Using config file "./xen_1". Error: Device 0 (vif) could not be connected. Hotplug scripts not working

I get this error in /var/log/xen/xen-hotplug.log

/etc/xen/scripts/locking.sh: line 60: perl: command not found

share|improve this question

closed as unclear what you're asking by Nils, Wesley, mdpc, Rex, Ward Apr 20 '14 at 8:28

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question.If this question can be reworded to fit the rules in the help center, please edit the question.

1 Answer 1

up vote 3 down vote accepted

You have to install perl to get it working. Try

# yum install perl

You can test whether it's working by issueing:

$ perl -e 'print("Hello, world!\n");'
Hello, world!

If it still does not work, check the script that issues the error and look whether it eventually resets the PATH variable. It's also possible that the start script starts Xen without the directory containing perl in $PATH. You could prevent this by finding out where your perl binary is located:

$ which perl
/usr/bin/perl

and adding a line like

export PATH="${PATH}:/usr/bin"

at the beginning of the locking.sh script.

Also note that since Xen version 4.3 the xm tool (like xend) is deprecated in favor of xl.

share|improve this answer
    
I installed but not working and the same error :( –  motaz Apr 18 '14 at 15:43
    
the perl working –  motaz Apr 18 '14 at 15:54
    
the line cause the problem : rightfile=$( perl -e ' open STDIN, "<&'$_lockfd'" or die $!; my $fd_inum = (stat STDIN)[1]; die $! unless defined $fd_inum; my $file_inum = (stat $ARGV[0])[1]; print "y\n" if $fd_inum eq $file_inum; ' "$_lockfile" ) –  motaz Apr 18 '14 at 16:05
    
Please see the update of my post, especially the last part about the $PATH. –  Andreas Wiese Apr 18 '14 at 16:20
    
thank u, but not working :( –  motaz Apr 18 '14 at 16:33

Not the answer you're looking for? Browse other questions tagged or ask your own question.