Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I just spun up a new Ubuntu 14.04 server and have been having a bit of trouble getting the atd daemon to stop auto-launching. There's been a bit of changing around on the management of startup processes, and I've viewed dozens of web pages on upstart, sysv-rc-conf, and other start management systems (not to mention chk-config, which isn't available anymore on Ubuntu anyway)…

I tried using sysv-rc-conf, but with the configuration as follows, I still have atd running on reboot:

# sysv-rc-conf --list atd 
atd          0:off  1:off   2:off   3:off   4:off   5:off   6:off

Even though it's not upstart-compatible, I put "manual" into /etc/init/atd.override

I've also tried a couple of variant invocations of update-rc.d, but despite the promising output, atd still launches on reboot:

# update-rc.d atd disable 0123456
update-rc.d: warning:  start runlevel arguments (none) do not match atd Default-Start values (2 3 4 5)
update-rc.d: warning:  stop runlevel arguments (none) do not match atd Default-Stop values (0 1 6)
 Disabling system startup links for /etc/init.d/atd ...
 Removing any system startup links for /etc/init.d/atd ...
   /etc/rc0.d/K80atd
   /etc/rc1.d/K80atd
   /etc/rc2.d/K80atd
   /etc/rc3.d/K80atd
   /etc/rc4.d/K80atd
   /etc/rc5.d/K80atd
   /etc/rc6.d/K80atd
 Adding system startup for /etc/init.d/atd ...
   /etc/rc0.d/K80atd -> ../init.d/atd
   /etc/rc1.d/K80atd -> ../init.d/atd
   /etc/rc6.d/K80atd -> ../init.d/atd
   /etc/rc2.d/K80atd -> ../init.d/atd
   /etc/rc3.d/K80atd -> ../init.d/atd
   /etc/rc4.d/K80atd -> ../init.d/atd
   /etc/rc5.d/K80atd -> ../init.d/atd

I'd prefer not to just brute-force it and whack the scripts, but after all this, that's what I'm tempted to do. Are there any recommended (or just practical and maintainable) ways to deal with startup issues like this in Ubuntu 14.04?

share|improve this question

1 Answer 1

Looks like everything works like upstart is supposed to (I had put my files in the wrong directory!):

I just did the following:

echo "manual" > /etc/init/atd.override

and voila -- the atd process no longer starts up on reboot!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.