Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am trying to mount a folder workspace from server to the client over NFS. For this I bind the folder to an /export by adding the following in my /etc/fstab on server:

/home   /export none    bind

Then I add the following lines in my /etc/exports on my server:

/export     *(ro,sync,no_subtree_check,insecure,fsid=0) 
/export/workspace   *(rw,sync,no_subtree_check,insecure,nohide) 

I load the exportfs file, and restart the nfs-kernel-server:

# exportfs -vr
# service nfs-kernel-server restart

I now go to my client and check which folders can be exported:

# showmount -e
Export list fo
/export/workspace *
/export           *

But when I try mounting the folder, I get the following error:

$ sudo mount -t nfs4 nfs/ -v
mount.nfs4: timeout set for Sat Apr 19 19:16:51 2014
mount.nfs4: trying text-based options 'addr=,clientaddr='
mount.nfs4: mount(2): No such device
mount.nfs4: No such device

I have also tried mounting /export/workspace and /home/workspace but that gives me the same error. I have tried loading the NFS module using modprobe on both client and server, but the module is loaded on both client and server.

share|improve this question
What is in the logs on the NFS server? Also don't waste your time trying to use exports that don't exist! – Michael Hampton Apr 20 '14 at 15:29
Thanks @MichaelHampton for your reply. The logs only showed me the same error: no such device. The problem lied with my kernel config file. see the details below. – Shehbaz Jaffer Apr 20 '14 at 19:25
up vote 1 down vote accepted

Solved the problem after 3 days!!

I tried mounting the nfs4 server folder from a client with a newer Kernel version (3.8). I was able to do so. So I copied the configuration file /boot/configure-3.8-generic file to my /usr/src/.config, and enabled the option Filesystems -> Network File Systems -> NFS3 client load as module and NFS4 client load as module.

compiled my kernel again, created initrd image, updated grub, and now I am able to mount the server folder from my 2.6 kernel client also!

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.