Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm unable to run the Active Directory Rights Management Services administration console after adding the role to a Windows Server 2008 R2 server.

Before adding the role, I created a new website in IIS called WRMS. I set the site to use SSL, assigned our certificate to it, and added a host name wrms.ourdomain.com to the site bindings. During the Add Role process, I pointed the wizard to this site when asked where to host the WRMS administration site.

The role installed successfully, however, when I attempt to open the Active Directory Rights Management Services administration console, I get the following error popup:

The connecting with local AD RMS administration service failed because the value of "AdminLocalConnectionPoint" under registry key "HKEY_LOCAL_MACHINE\Software\Microsoft\DRMS\2.0" was invalid.

The value of that registry key is https://wrms.ourdomain.com. I don't see anything relevant in the application logs.

Thank you

share|improve this question

1 Answer 1

The RMS blog has a post about issues/workarounds when installing SSL with RMS (note this is for RMS for Windows Server 2003):

Whew! Now for the fun stuff. To enable SSL in your RMS environment after the RMS server has been provisioned, you should follow these steps:

You may need to use the ADScpRegister utility from (included wtih RMS for Windows Server 2008, located in "C:\Program Files\RMS SP2 Administration Toolkit" ) to re-register the the URL: ADScpRegister unregisterscp

Here is a guide for installing RMS on Windows Server 2008, that discusses the ADScpRegister utility.

share|improve this answer
    
I don't have an explicit requirement for the WRMS administration site to use SSL. Didn't think it would cause me such frustration :) I'm going to remove the role and reconfigure it so the WRMS site doesn't use SSL. Thanks for your help, shufler –  George Durzi Aug 26 '09 at 19:08

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.