Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

When issue the command htop on my RHEL5 box I get a normal view, however when I scroll down I have several "blank" command ranges as can be seen here:

enter image description here

Can someone explain me how this happens/occurs?

Update:

my .htoprc file:

# Beware! This file is rewritten every time htop exits.
# The parser is also very primitive, and not human-friendly.
# (I know, it's in the todo list).
fields=0 48 17 18 38 39 40 2 46 47 49 1
sort_key=46
sort_direction=1
hide_threads=0
hide_kernel_threads=1
hide_userland_threads=0
shadow_other_users=0
show_thread_names=0
highlight_base_name=0
highlight_megabytes=1
highlight_threads=0
tree_view=0
header_margin=1
detailed_cpu_time=0
color_scheme=0
delay=15
left_meters=AllCPUs Memory Swap
left_meter_modes=1 1 1
right_meters=Tasks LoadAverage Uptime
right_meter_modes=2 2 2
share|improve this question

2 Answers 2

Should be in .config/htop/htoprc or something similar.

I'd say you have this line in your config file

shadow_other_users=1

You should put it at 0. Otherwise if you start htop with your user it will shadow other users' processes. Can you please post your htoprc file if this doesn't work?

share|improve this answer
    
Hi, it already was set to 0. I've updated the post with the htoprc file which was located in /root/.htoprc –  timmeyh Apr 24 at 8:27
    
I see, under which user do you run htop ? Can you see other processes other than init ? Did it work good already or is the problem there since the beginning ? –  pat Apr 24 at 8:37
    
I run htop as the root user. This didn't happen in the begin. I can still see other processes with normal output. Because this are low pids I think they are some kernel threads that have gone wrong. I also aknowledge that an uptime of 1024 days may have something to do with it. –  timmeyh Apr 24 at 8:55
    
Ah, that's true, that could happen. The only parameter I know I gave you, so good luck now. –  pat Apr 25 at 14:46

I found that for Red Hat EL 5 and htop 1.0.3 I had to make the following code change to get the command to show up for root processes. I did not need to make this changes to Red Hat 6 EL.

--- Process.c   2014-01-01 12:00:00.000000000 -0400
+++ Process.c.patched   2014-01-01 12:00:00.000000000 -0400
@@ -52,7 +52,7 @@
 #define PROCESS_FLAG_CGROUP 16

 #ifndef Process_isKernelThread
-#define Process_isKernelThread(_process) (_process->pgrp == 0)
+#define Process_isKernelThread(_process) (_process->pgrp == 1)
 #endif

 #ifndef Process_isUserlandThread
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.