Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

When accessing pdf files on a sharepoint site, I'm getting a warning saying

"Some files can harm your computer. If the file information loks suspicious or you do not fully trust the source, do not open the file."

Is there a way to switch off the warning?

NOTE: removing the "confirm open after download" check did not help.

share|improve this question
add comment

8 Answers 8

IIRC, you may need to modify the Security Settings in IE for the specific zone that the site is in where you're downloading the PDF (I'm assuming Local Intranet Zone for Sharepoint). Tools->Internet Options->Security tab->Select zone->Custom level, and then scroll down to "ActiveX controls and plug-ins," and you will have to Enable or Disable some of the prompting/downloading items.

share|improve this answer
1  
+1; always check the zone first and foremost. Check what version of IE your clients are using too, as the security model has changed a bit recently. –  Jimmy Shelter Aug 26 '09 at 18:03
    
It's amazing that no-one got deep enough to detail that there's a security setting in the default "Medium" and lower trust levels that sets "Launching applications and unsafe files" to "Prompt", while "Local intranet" by default uses the default "Medium-low" trust level, where this setting is set to "Enable". Simply listing your domain in the Local intranet should solve the issue. –  Alexey Krasheninnikov Jul 9 '12 at 19:55
add comment

This is a client side (Internet Explorer/Windows) problem more than a SharePoint problem. On the client, if you do the following:

  1. Go into Windows Explorer
  2. Select "File Types"
  3. Find the PDF file type
  4. Click the Advanced Button
  5. Uncheck "confirm open after download"
  6. Click OK on the screens
share|improve this answer
    
Thanks, I tried that but the problem remains... –  Paolo Tedesco Aug 26 '09 at 16:26
    
This solved the problem for me. –  Jim Feb 1 '10 at 16:35
add comment
up vote 2 down vote accepted

Thank you all for your help; I've found out that the problem was actually due to browser incompatibility with IE8 - must install SharePoin SP2 for IE8 to be correctly supported...

Check this technet link: Plan browser support (Office SharePoint Server).

share|improve this answer
add comment

If you have Adobe Reader installed, opened PDFs ignore the Windows settings that MattB mentions. This is because Adobe install an ActiveX control into Internet Explorer that changes the open behaviour.

You need to check the preferences of Adobe Reader to see if the setting can be disabled.

share|improve this answer
    
This didn't help as well... thanks anyway. –  Paolo Tedesco Aug 26 '09 at 16:48
add comment

One more Sharepoint 2010 fix which worked for me is:

go to Central Admin >> Manage Sites >> select your site and click it to highlight it.

Then Select "General Settings" from ribbon.

in section "Browser File Handling" select "Permissive" instead of "Strict"

Done

share|improve this answer
add comment

I know this question is solved, but an alternative way of eliminating this warning for IE7 was adding the SharePoint site as a trusted site.

share|improve this answer
    
In some companies the Trusted sites are considered less secure than Local intranet and use the default Medium security level which forces the browser to continue prompting despite the site being trusted. See my answer. –  Alexey Krasheninnikov Jul 9 '12 at 20:04
add comment

This issue does not depend on any version of SharePoint whatsoever and is not primarily related to SharePoint either. It is a browser security zone setting and dialog box enhancement of Internet Explorer since IE6 SP1 described here: KB 821968.

Yes, you can disable the browser add-on breaking the create and edit new Office documents functionality of SharePoint aka Client Integration.

Yes, you can fiddle with File Types settings, but in the end all of these solutions help breach the security of your PC instead of accurately solving the issue where it can be solved more legitimately.

It's amazing that no-one got deep enough to detail that there's a security setting in the default "Medium" and lower security levels that sets "Launching applications and unsafe files" to "Prompt", while "Local intranet" by default uses the default "Medium-low" security level, where this setting is set to "Enable".

Simply listing your domain in the Local intranet instead of Trusted Sites should solve the issue described here as well as some of the SSO issues out there automatically.

share|improve this answer
add comment

I found that these 2 add-ons were running, and once disabled the warning box went away SharepointOpenDocument Class and SharePoint Stssync Handler

Go to Tools and Manage add-ons, look for these 2 add-on and click disable

Hope this Helps for some, It worked for me.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.