Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Having a really strange and frustrating issue with system clocks across a few (non virtualized) Ubuntu 12.04 servers. The system clock jumps unpredictably by over 50 seconds. Here's a part of the loopstats file while using ntp:

56771 23997.310 -0.047256373 137.252 0.001375363 0.890170 6
56771 24128.310 -0.046362694 136.890 0.001324765 0.842457 6
56771 24653.310 -0.045759170 135.458 0.001257441 0.936651 6
56771 25044.310 -0.046735096 134.368 0.001225792 0.957048 6
56771 25709.230 55.036447898 500.000 19.474846146 835.061099 6
56771 25839.229 54.982964496 500.000 18.217060299 795.518729 6
56771 26361.229 54.879192791 500.000 17.040539054 958.219344 6
56771 26558.229 54.696000559 500.000 15.940096291 924.646625 6
56771 27079.229 54.488025136 500.000 14.910776062 1051.659882 6
56771 27599.241 54.461708446 500.000 13.947756952 1150.613602 6

This jump occurs whether ntp client is running or not, so it does not appear to be an ntp software issue. I've also tried the openbsd ntp client, and the latest ntp dev version.

There is nothing in the process list that can conceivably change the system clock around the times that this occurs.

The hwclock still shows correct time while the system clock is incorrect, so it does not appear to be the CMOS clock either. The only recent event was that the servers were unplugged for over an hour, so I'm not ruling out some strange hardware clock issue.

My available clock sources are:

cat /sys/devices/system/clocksource/clocksource0/available_clocksource 
tsc hpet acpi_pm 

I've tried tsc and acpi_m with the same result.

Any help is appreciated thanks!

share|improve this question
Are you sure you don't have some second tool trying to set the time, perhaps via cron? Is there anything mentioned in your syslog around the same time as a time-jump? – Zoredache Apr 24 '14 at 17:06
I wish there was something in the syslog! There are no cronjobs scheduled around the times of the events. – user160922 Apr 24 '14 at 17:19
up vote 0 down vote accepted

The issue was a clock out of sync on the Domain Controller which was causing the centrify client to update its clock incorrectly. The option

adclient.sntp.enabled: false

in centrify.conf disables clock syncing to the domain.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.