Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have a little problem with my plesk installation at the moment and unfortunately do not have enough knowledge to solve it on my own. I would therefore be glad if I could get a hint on this.

I tried to log in into my Plesk but I can't proceed due to the following error:

Internal error: Unable to exec utility listmng: listmng: listmng: Cannot find grep program System error 2: No such file or directory

File Unix.php

Line 147

Type PleskUtilException

I'm running Plesk 11.5.30 on Ubuntu 10.04. What's strange is that I didn't make any changes on the server lately. At least not that I'm aware of.

I tried running plesks "bootstrap.sh repair" and uninstalled the mailman but I keep getting the error.

When I run /opt/psa/admin/sbin/listmng via ssh I get the same error, so I guess it's not able to use the grep command. I don't know how to solve that problem though.

I'd appreciate any kind of help.

share|improve this question

closed as off-topic by EEAA, mdpc, MichelZ, Wesley, dawud Apr 26 at 7:55

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions must be relevant to professional system administration. Server Fault is dedicated to professional system and network administrators. End user and enthusiast questions are off-topic (contact your system administrator or hire a professional to help you out). Please see the Help Center for more information." – EEAA, mdpc, MichelZ, Wesley, dawud
If this question can be reworded to fit the rules in the help center, please edit the question.

    
I really don't understand why you were voted down as this appears to be a very valid question with regards to Plesk systems administration. I've attempted an answer. –  Eugene van der Merwe Apr 25 at 2:17

1 Answer 1

up vote 0 down vote accepted

You might want to start off by looking if grep is on your system with grep -V which will reports the version (and if it exists in the path).

If grep is not there I would worry about the integrity of your operating system. Grep is pretty standard and normally always found in the path.

If grep is missing you might want to examine the path with export on a healthy system to see if essential system folders are missing from the path.

On my healthy Ubuntu 13.04 the path reports:

PATH="/usr/lib/lightdm/lightdm:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games"

On this system the grep utility can be located in /bin and the system wide path is set in /etc/environment.

If you don't succeed using with troubleshooting the operating system / Plesk installation I would seriously consider contacting Plesk. There might be a cost to logging a ticket with them but at the same time the support for their product is excellent.

And finally you could try logging the problem on the Parallels forum (http://forum.parallels.com). Although it's technical community based support it's generally very active and you might even find a Parallels engineer lurking there. I have found that although ServerFault is a great systems administration Q&A site Plesk problem are better addressed elsewhere.

share|improve this answer
    
Thank you for your help here. Grep is installed system wide, however I marked your answer as accepted for pointing out that the plesk forum might be a better place to ask for plesk related questions. –  a.selle Apr 25 at 7:41

Not the answer you're looking for? Browse other questions tagged or ask your own question.