Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Recently I added a second network interface to my Domain Controller, and assigned a private subnet to provide a iSCSI volume for backups, but the IP address from this interface is being propagated to my DNS server.

So now, when I use nslookup against my domain, one of the responses is this private IP address.

How can I prevent this interface from updating DNS with its IP address?

This is a Windows Server 2012 R2 Domain Controller that's virtualized through XenServer 6.2 SP1.

share|improve this question

1 Answer 1

up vote 3 down vote accepted

In the network adapter's advanced DNS properties, clear the check in the box for Register this connection's addresses in DNS.

The location of that setting is about 3/4 of the way down the page here: http://technet.microsoft.com/library/dd163570.aspx

share|improve this answer
    
Wow, really simple. I just can't understand why this is enabled by default. Thanks a lot. –  Maurício Mota Apr 25 at 0:49
1  
It's enabled by default because 99.99999% of the time you want computers to register their IP addresses in DNS. If you didn't have this set, you'd have to configure DHCP proxy updates which are ugly (and doesn't solve the problem for statically assigned adapters) or manually create DNS records for every server. Not having that box checked is the exception, not the rule. –  MDMarra Apr 25 at 0:54

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.