Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am trying to installation CentOS through pxe tftp installation. Installation starts but it fails to download image files from the http server. but file are accessible on the http server. Logs from the installing system are following.

Unable to retrieve the //abc.com/CentOS6.5/ks.cfg file.
INFO  : transferring //abc.com/CentOS6.5/images/updates.img
ERROR : Error downloading //abc.com/CentOS6.5/images/updates.img: HTTP response code said error
INFO  : transferring //abc.com/CentOS6.5/images/product.img
ERROR : Error downloading //abc.com/CentOS6.5/images/product.img: HTTP response code said error
INFO  : transferring //abc.com/CentOS6.5/images/install.img
ERROR : Error downloading //abc.com/CentOS6.5/images/install.img: HTTP response code said error

(above links are http. cannot put links because i'm new here.)

I've tried following solutions that I found on the internet:

  • Tried disabling the iptables completely.
  • Tried restoring default SELINUX context for /var/lib/tftpboot
  • Tried Disabling SELINUX.

Unfortunately there is no http response code available. I've checked all the access logs.

Any suggestion are much appreciated.

share|improve this question
    
Are you passing correct network information to Anaconda via kernel parameters? If yes then you should boot with some LiveCD and check if the HTTP resource you are trying to download is actually available at that URL from that computer. –  Florin Asavoaie Apr 25 at 11:35
    
please post the kickstart file (removing any sensitive information). I have always liked this site for kickstarts: fedoraproject.org/wiki/Anaconda/Kickstart –  natxo asenjo Apr 25 at 21:19
    
I was booting virtual machine. Looks like the ethernet virtualization did not support booting through pxe. So it used to take ip from dhcp and than could not move ahead. Changing ethernet type solved the problem. Thanks @ Florin Asavoaie and natxo asenjo for help. –  Khatri_G May 1 at 4:51

1 Answer 1

if you are retrieving components by HTTP then I think your urls do not look right.

INFO  : transferring //abc.com/CentOS6.5/images/updates.imgerror

it seems it should look like

INFO  : transferring http://abc.com/CentOS6.5/images/updates.img

this means you might have to check the url definition

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.