Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I recently transferred my domain to GoDaddy (garrypettet.com). Everything seemed to go smoothly. I have a server with DigitalOcean, managed by ServerPilot. The website was fine until a few moments ago.

Now when I visit garrypettet.com, I am shown an error page saying that the site is in maintenance mode. The odd thing is that the title of the page says "Vapor Hub International" which, from what I can see, is a totally unrelated website to me. The page that is being displayed I don't think is being served up by my server.

I have no idea how to debug this problem. Is it an oddity with DNS? I have restarted my server to no avail.

share|improve this question
    
Right now your domain is resolving to the ip address 95.85.51.99. Only you know if that's correct or not. If not, then log into your DNS control panel (at GoDaddy) and correct it. –  joeqwerty Apr 26 at 15:03
    
Thats correct. I have a few subdomains also pointing at that IP address (e.g: thoughts.garrypettet.com) and they display correctly. Typing the IP 95.85.51.99 actually shows the correct page but typing garrypettet.com shows this weird Vapor Hub message. I've no affiliation with Vapor Hub and can't figure out why this is displaying –  Garry Apr 26 at 15:11
    
When I open my browser to garrypettet.com I get a page with an icon/button in the middle that states "You have arrived.". When I click the icon/button I'm redirected to laravel.com. –  joeqwerty Apr 26 at 15:14
    
I see the test page for the Laravel PHP framework. Is that what you're expecting? –  Bert Apr 26 at 15:14

1 Answer 1

up vote -2 down vote accepted

What DNS server are you using on the computer you are trying to visit the website with? Perhaps you are using a server that doesn't have the updated DNS record for your domain.

nslookup www.garrypettet.com
Server:     8.8.8.8
Address:    8.8.8.8#53

Non-authoritative answer:
www.garrypettet.com canonical name = garrypettet.com.
Name:   garrypettet.com
Address: 95.85.51.99

That is what I get on my machine. Is it possible to change your DNS settings to use Google DNS servers (8.8.8.8, 8.8.4.4)?

Another thing you can do is make an entry in your HOSTS file for your domain. That will avoid querying your DNS server, and that can be used as a temporary fix until it is updated.

Create a line at the bottom of your HOSTS file like this one, using this guide.

95.85.51.99 garrypettet.com
share|improve this answer
    
The problem was that I had been using my iPhone to tether my laptop for a few days and the DNS hadn't propagated to my iPhone. I waited another 24 hours and the problem solved itself. Still unsure as to how "Vapor Hub International" factored into things... –  Garry Apr 28 at 22:06

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.