Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

1 linux host on amazon with Apache as webserver and 3 virtual domains configured on it. also SNI is used , also all the 3 domains have SSL installed on them Whenever access any of these domains the browser always fetches SSL certificate of the first domain. why ?

share|improve this question

closed as off-topic by Jenny D, Jacob, mdpc, RobM, Mathias R. Jessen Apr 29 at 22:37

This question appears to be off-topic. The users who voted to close gave these specific reasons:

  • "Questions must demonstrate a minimal understanding of the problem being solved. Try including attempted solutions, why they didn't work, and the expected results. See How can I ask better questions on Server Fault? for further guidance." – Jenny D, Jacob, Mathias R. Jessen
  • "Questions must be relevant to professional system administration. Server Fault is dedicated to professional system and network administrators. End user and enthusiast questions are off-topic (contact your system administrator or hire a professional to help you out). Please see the Help Center for more information." – mdpc, RobM
If this question can be reworded to fit the rules in the help center, please edit the question.

    
Your question needs some improvement from you. In it's current state it lacks a lot of information (e.g. error messages, steps you have tried, research you have done). For help, visit the help center and specifically how do I ask a good question. Also, please include your httpd.conf –  MichelZ Apr 29 at 8:27
    
apache provides natively SNI; hence MichelZ is totally right asking for your httpd.conf file –  philippe Apr 29 at 8:30
    
Apache may or may not provide SNI depending on version; the client may or may not use SNI depending on OS, browser or version. –  Jenny D Apr 29 at 10:56

2 Answers 2

SNI is not universally supported so you can only reliably have one SSL site per IP because virtual domains by host header require access inside the encrypted payload.

share|improve this answer

Okay, given your little information the only options, that are almost always working are:

  1. Get one IP per virtual host

or

  1. Get a Certificate that includes those 3 Domain names

Because that way you can eliminate the most commont point: Misconfigured or missing SNI.

Also, please post your anonymized error log (usually in /var/log/apache2/error.log) and the httpd.conf + included configs, so that we can provide better answers. It may me, that SNI is not compiled into your Apache or you are not using mod_ssl for the SSL-connections.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.