Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

ASP pages don't seem to be working if they contain any ASP code. Is there a way to test the setup of IIS6?

share|improve this question
    
Are you talking classic asp or asp.net? If the latter which version? –  Adam Fox Aug 26 '09 at 19:26
    
You don't happen to use SiteMinder on this server do you? –  Dustin Aug 26 '09 at 20:27
    
Classic ASP, mostly the ASP.NET on the server is working. –  digiguru Aug 27 '09 at 0:09
    
No Siteminder installed here. –  digiguru Aug 27 '09 at 0:12
    
Just FYI - This case wasn't an issue with ASP pages, activity from other processes were killing the server. ASP pages were the first against the wall. Seemingly the rest of the site was working, but these pages turned out to be cached. –  digiguru Aug 27 '09 at 0:20

2 Answers 2

up vote 3 down vote accepted

Without knowing the error(s) that you're receiving or symptoms of the problem it's hard to narrow down what you're dealing with and provide a solution.

However, to cover the basics:

  • Make sure ASP is installed on your IIS box. If this is ASP.NET make sure you've installed the proper version of the .NET framework.
  • Make sure ASP is enabled as a web extension
  • If this is ASP.NET you can run aspnet_regiis -i from the installation folder of the .NET version you're working with to make sure it gets registered with IIS. The folder you'll want to look in is %systemroot%\Microsoft.NET\Framework\[specific version folder]\
  • Make sure you have configured an application on your web site or in the directory that holds your ASP code.
share|improve this answer
    
All very useful points, thankyou squillman –  digiguru Aug 27 '09 at 0:18

In IIS on the site, right-click and select Properties. In the dialog that brings up, select the "Home Directory" tab and click on "Configuration..." and look for what "App Mappings" does the .asp extension have? Is it "C:\WINNT\system32\inetsrv\asp.dll"? That is where I'd start for tracking down the problem.

share|improve this answer
    
Thanks - this helps identify that ASP is indeed installed, thanks! –  digiguru Aug 27 '09 at 0:09

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.