Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I donwloaded pfsense live cd 2.1.3 and now I want to run pfsense from an usb cdrom drive.

It loads a while and than crahses with "unable to mount ..."

I know I have to choose boot option 3 in order to boot from an usb cdrom but I don't see this menu.

enter image description here

The computer just boots. Do I need to press a specfic key to bring up this menu or is this maybe missing on the current iso?

share|improve this question
Are you sure about that? Isn't it just "too fast"? Also, I don't think that you need the USB device option. – MichelZ May 7 '14 at 17:06
@MichelZ - I sure need it - - Anyway I solved it, it was not too fast, it only took forever. – Jürgen Steinblock May 8 '14 at 5:53
Thanks for the Info. Could you post an answer on how you solved it? – MichelZ May 8 '14 at 5:57
up vote 1 down vote accepted

Solved it,

to boot from USB Drive, you need boot option number #3

Booting from USB

If the boot stops with a mountroot error while booting off the live CD, usually with USB CD/DVD drives, escape to the loader prompt and run the following: set"10000" boot

On 2.0 this is on the boot menu - option #3 to boot from USB devices.

I just thought the prompt would come very early, like grub or something. But it turned out I had to wait about five minutes (old hardware with USB 1.1 only) for it to show up. And it vanishes after 10 seconds, I think I just missed it the first few tries.

share|improve this answer
Great work solved my exact same problem – Jeremy Hajek May 20 '15 at 21:19

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.