Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am following mongo site (http://docs.mongodb.org/manual/tutorial/install-mongodb-on-red-hat-centos-or-fedora-linux/ ) to install mongo on my centos 5.1o

I am getting following errors

sudo yum install mongodb-org
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * atomic: www8.atomicorp.com
 * base: mirrors.tummy.com
 * epel: mirror.compevo.com
 * extras: mirror.raystedman.net
 * rpmforge: mirror.team-cymru.org
 * updates: mirror.steadfast.net
atomic                                                                        | 1.9 kB     00:00     
base                                                                          | 1.1 kB     00:00     
c5-testing                                                                    | 1.9 kB     00:00     
epel                                                                          | 3.7 kB     00:00     
extras                                                                        | 2.1 kB     00:00     
rpmforge                                                                      | 1.9 kB     00:00     
updates                                                                       | 1.9 kB     00:00     
Reducing CentOS-5 Testing to included packages only
Finished
Setting up Install Process
Resolving Dependencies
There are unfinished transactions remaining. You might consider running yum-complete-transaction first to finish them.
The program yum-complete-transaction is found in the yum-utils package.
--> Running transaction check
---> Package mongodb-org.i686 0:2.6.1-1 set to be updated
--> Processing Dependency: mongodb-org-server = 2.6.1 for package: mongodb-org
--> Processing Dependency: mongodb-org-shell = 2.6.1 for package: mongodb-org
--> Processing Dependency: mongodb-org-mongos = 2.6.1 for package: mongodb-org
--> Processing Dependency: mongodb-org-tools = 2.6.1 for package: mongodb-org
--> Running transaction check
---> Package mongodb-org-mongos.i686 0:2.6.1-1 set to be updated
---> Package mongodb-org-server.i686 0:2.6.1-1 set to be updated
---> Package mongodb-org-shell.i686 0:2.6.1-1 set to be updated
---> Package mongodb-org-tools.i686 0:2.6.1-1 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

=====================================================================================================
 Package                         Arch              Version                Repository            Size
=====================================================================================================
Installing:
 mongodb-org                     i686              2.6.1-1                mongodb              4.6 k
Installing for dependencies:
 mongodb-org-mongos              i686              2.6.1-1                mongodb              6.7 M
 mongodb-org-server              i686              2.6.1-1                mongodb              8.9 M
 mongodb-org-shell               i686              2.6.1-1                mongodb              4.2 M
 mongodb-org-tools               i686              2.6.1-1                mongodb               88 M

Transaction Summary
=====================================================================================================
Install       5 Package(s)
Upgrade       0 Package(s)

Total size: 108 M
Is this ok [y/N]: y
Downloading Packages:
Running rpm_check_debug
ERROR with rpm_check_debug vs depsolve:
mongo-10gen-server conflicts with mongodb-org-server-2.6.1-1.i686
mongo-10gen-tools conflicts with mongodb-org-tools-2.6.1-1.i686
mongo-10gen-shell conflicts with mongodb-org-shell-2.6.1-1.i686
mongo-10gen-mongos conflicts with mongodb-org-mongos-2.6.1-1.i686
mongo-10gen conflicts with mongodb-org-2.6.1-1.i686
Complete!
(1, [u'Please report this error in http://bugs.centos.org/yum5bug'])

What can I do to fix these and get mongo going

Thanks

share|improve this question

1 Answer 1

Your package conflict with older version of mongodb. Package mongo-10gen is mongodb 2.4 (references here). To resolve that, just uninstall the conflicting packages

sudo yum remove mongo-10gen-server mongo-10gen-tools mongo-10gen-shell mongo-10gen-mongos mongo-10gen

Then install again mongodb

sudo yum install mongodb-org
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.