Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Am attempting to start using SCCM 2012 to image and maintain new machines. Have unpacked a win7 x64 .iso file to a network share and am trying to add it to SCCM via the Software Library/Operating Systems/Operating System Images. When I navigate to the 'install.wim' file I get the message:

The specified UNC path does not contain a valid WIM file or you do not have 
permission to access it. Specify a valid path.

My connection to the file server has all privileges (in so far as I can tell). I am able to create / delete files and folders on it as well as run applications. Looking at the file server I don't see any errors or other indications that permissions are lacking.

EDIT: went to 'file/properties' for install.wim. Updated to ensure that everybody has full control. Note that there isn't an associated 'open with' for the '.wim' file type. Is this a problem?

share|improve this question
1  
Have you tried re-extracting the .wim file? Maybe it's just corrupt. –  MichelZ May 9 at 11:13
    
Just tried this. Same result. –  ethrbunny May 9 at 11:57
    
Agree with MichelZ, as long as you've checked the permissions, it is not uncommon for a .wim file to be corrupted during the extraction (or transfer) process. –  out-null May 9 at 13:43
    
Can you try moving it to a different fileserver? –  BigHomie May 16 at 14:21

1 Answer 1

Can I ask what command switches you used to create the .wim file with? Namely, I am looking for switches like /compress because I have found -in personal experience- that trying to compress .wim files during extraction can often lead to this type of problem. If space is not too much of an issue, try re-extracting the .wim with no compression. (it may mean a "thick" image may come out to roughly 8-10 GB in size vrs high compression of about 4-6GB)

Note* You mentioned that there is no known file association properties with the .wim file, this is normal behavior as .wim files can only be manipulated with specific tools: 1.) Windows ADK/Deployment and Imaging toolkit(s) - GUI 2.) Imagex - command line tool for Windows 2003-2008 3.) DISM - command line tool (replacing) ImageX - lots of options here rolled into one command line tool, definitely look it up if you are not already using this instead of the dated Imagex.

One thing to note, although I have not had problems with this before, but if you are using Imagex; and Server 2012 is supported to handle DISM created images, there may be something you may want to look into. Hope this helps.

share|improve this answer
    
I didn't create the .wim file. This is the Windows 7 x64 installer. –  ethrbunny May 9 at 15:52
1  
Well, there is the problem right there! Something to note: there are actually 2 separate .wim files that are required for SCCM to successfully deploy an image. The first .wim is just a specialized .wim file that loads a stripped down OS that allows the computer to download and install the actual image. The second .wim you need is one that you create that will be loaded into SCCM where you are experiencing the problem. technet.microsoft.com/en-us/library/hh825072.aspx check out this link to see how to create a .wim through CLI, otherwise, SCCM has a capture image feature built in. –  out-null May 9 at 16:05
    
Point being in that previous rant. Are you trying to add the correct .wim files to to correct places? –  out-null May 9 at 16:12
    
I have extracted the contents of the win 7 iso file to a network share. From here I'm trying to import the initial OS image. See step 3.7 here: toolzz.com/?p=879 –  ethrbunny May 9 at 18:52
    
I checked the link, I do not see a section 3.7 though. :( But I think I know where you are getting stuck at. Just as a precaution, can you left-click the .wim file you are trying to import and check properties --> General --> Attributes and see anything funny going on there? –  out-null May 9 at 20:09

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.