Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Since yesterday I suddenly stumbled upon a very absurd problem.

My setup is an ESXi 5.1 home server with two VMs: a Debian (for mail, printing, webhosting, telephony, and more) and a ZFSGuru (FreeBSD 10, file server).

The only role of the FreeBSD VM is a ZFS file server.

Everything works great. I mean, worked great. Since yesterday the entire ESXi server locks up if I use the FreeBSD VM.

I found out about this when I was browsing a SMB share hosted by the VM in question and everything froze. I soon found out that the same thing happens if I try to access the web interface or some certain things over SSH.

I'm not sure what exactly triggers it (CPU usage, I/O, network) but it only happens on the FreeBSD VM. While the Debian VM is affected if the system freezes, I can't trigger the problem on the Debian VM.

When I say the server hangs, I mean that I can't access any VM on the server, nor access it via vSphere client or ping it.

ESXi's vmkernel.log contains the following errors:

2014-05-09T11:45:50.456Z cpu1:4550)WARNING: LinNet: netdev_watchdog:3220:NETDEV WATCHDOG: vmnic1: transmit timed out

2014-05-09T12:33:27.066Z cpu1:6063)NetPort: 1586: disabled port 0x2000005

2014-05-09T12:34:09.476Z cpu0:6064)NetPort: 1392: enabled port 0x2000005 with mac 00:0c:29:39:02:c7

There's nothing to be found in the FreeBSD VM's logs.

I have no idea where this problem came from. The only thing that may be related, is that I rebooted the FreeBSD VM to tune a l2arc setting (vfs.zfs.l2arc_noprefetch to be specific) the day before. I already reverted this to rule that out.

I already tried patching ESXi. Didn't help. I can't really update FreeBSD. I tried to update the ports, but that triggered the problem.

share

migration rejected from superuser.com May 9 at 13:04

This question came from our site for computer enthusiasts and power users. Votes, comments, and answers are locked due to the question being closed here, but it may be eligible for editing and reopening on the site where it originated.

closed as off-topic by Iain, John, Chopper3, Jacob, Dennis Kaarsemaker May 9 at 13:04

  • This question does not appear to be about professional server, networking, or related infrastructure administration within the scope defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

6  
This question appears to be off-topic because it is about a home server tour refers. –  Iain May 9 at 12:19
    
@lain: I'm not sure if I understand. You mean that my question doesn't belong in ServerFault since it's at home? I posted it in SuperUser but it got moved to ServerFault a few minutes before your comment. –  Compizfox May 9 at 12:29
    
What are you using for the NIC on the VM? I used to have problems with a certain NIC crashing the entire ESXi system, but 5.5 Update 1 corrected that. –  Nathan C May 9 at 12:37
    
@NathanC It's a Realtek RTL8111E. –  Compizfox May 9 at 12:41
    
@Compizfox What's the virtual NIC configured as? That's different. –  Nathan C May 9 at 12:42

Browse other questions tagged or ask your own question.