Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have a RHEL 5 box with php 5.3 that I am tasked with installing mssql support on. I installed php53-mssql and reloaded apache. It seems that modules were installed to /usr/lib/php/modules but my PHP modules are in /usr/lib64/php/modules (lib64). I couldn't just copy those modules into lib64 because they are not the correct ELF CLASS (probably wrong arch). When trying mssql_connect() I get an undefined function error in the Apache error log. How can I get this to work? php -m shows these DB modules, but no mssql ones.

PDO pdo_mysql pdo_sqlite mysql mysqli

share|improve this question
    
Have you tried just symlinking them? Did you uncomment the module in php.ini? –  Nathan C May 9 at 17:52
    
If they are the wrong type, I doubt symlinking will help, but Ill try. Yes I uncommented mssql.so in php.ini. –  usedTobeaMember May 9 at 18:30
    
Exactly where did you get this php53-mssql? –  Michael Hampton May 9 at 19:22
    
EPEL php53-mssql-5.3.3-1.el5.i386.rpm –  usedTobeaMember May 9 at 19:40
    
Have you tried downloading the 64bit one? –  AWippler May 11 at 13:48

1 Answer 1

You need to enable mssql module in php.ini. You need to uncomment this line:

extension=mssql.so

If you can't find it in php.ini, then just add it to the end of other extension definitions in your php.ini file. Restart apache after that.

share|improve this answer
    
I have that line already. –  usedTobeaMember May 11 at 15:51

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.