Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have a dedicated server. No PHP files were running when i use my website so i tried looking into the apache and used service https status to check apache status and this is what i am getting service httpd status

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.
Please contact the server administrator, root@mps-vm1 and inform them of the time the error occurred, and anything you might have done that may have caused the error.
More information about this error may be available in the server error log.

Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.

Apache/2.2.27 (Unix) mod_ssl/2.2.27 OpenSSL/1.0.1e-fipsmod_bwlimited/1.4 Server at localhost Port 80

Can someone please tell me what should i do?

share|improve this question
1  
You should do as it says and look in the error log. –  Iain May 12 '14 at 8:59
    
I'm confused: this error is displayed by the browser, while "service httpd status" should be typed into a terminal (and the answer should be one of "httpd is running (pid xxxx)" or "httpd not running") –  AndrewQ May 12 '14 at 9:29
    
no this message is displayed in the SSH terminal(putty) –  karan May 12 '14 at 10:02
    
IMHO your configuration is messed up. Start examinig "/etc/init.d/httpd", to discover why the error 500 comes up asking the pid of httpd (that is what service httpd status does) –  AndrewQ May 12 '14 at 10:16
    
@AndrewQ, Start by looking the the logs - they should contain valuable information about the error, it's location etc –  Iain May 12 '14 at 11:01

2 Answers 2

service httpd status will be retrieving Apache's /server-status/ page (provided by mod_status). It will be doing this via apachectl status (or apache2ctl if you're on Debian or Ubuntu)

This likely means that your configuration is not loadable. You can use apachectl configtest to test a configuration before reloading/restarting the webserver.

The error message, by default, will also be found in /var/log/httpd/error_log (or ssl_error_log, depending on how the request came in.) Those should be your first point of call in a situation such as this.

share|improve this answer
    
It could be a file called error.log (or something completely different too). –  Iain May 12 '14 at 13:02

So I solved the issue by reinstalling APACHE. That seemed to be the only way. Maybe when I was making changes to the installation files, I did something terribly wrong and messed up Apache.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.