Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am having the toughest time sending large attachments, everywhere I have checked my file size limit for send/receive is 100mb but yet users are unable to receive files even at the size of 14mb.

I'm using a spam filter (Appriver) and have worked with there support for a very long time, we see the following errors in logs

13:32:40.260 4 SMTP-000036([myserverIP]) rsp: 354 Start mail input; end with <CRLF>.<CRLF>
13:33:41.038 3 SMTP-000033([myserverIP]) write failed. Error Code=connection reset by peer
13:33:41.038 3 SMTP-000033([myserverIP]) [659500] failed to send. Error Code=connection reset by peer
13:33:41.038 4 SMTP([myserverIP]) [659500] batch reenqueued into tail

Windows firewall is disabled on the exchange server, all other emails that are of smaller value come through just fine.

Here is a print out of size limits:

ConnectorType   ConnectorName                    MaxReceiveMessageSize      MaxSendMessageSize
-------------   -------------                    ---------------------      ------------------
Send            InternetSendConnector            -                          35 MB (36,700,160 bytes)
Send            Appriver-Smarthost               -                          35 MB (36,700,160 bytes)
Receive         Default EXCHSRVR                 100 MB (104,857,600 bytes) -
Receive         Client Proxy EXCHSRVR            100 MB (104,857,600 bytes) -
Receive         Default Frontend EXCHSRVR        100 MB (104,857,600 bytes) -
Receive         Outbound Proxy Frontend EXCHSRVR 100 MB (104,857,600 bytes) -
Receive         Client Frontend EXCHSRVR         100 MB (104,857,600 bytes) -
Receive         ExchangeRelay                    100 MB (104,857,600 bytes) -
TransportConfig -                                100 MB (104,857,600 bytes) 10 MB (10,485,760 bytes)
ADSiteLink      DEFAULTIPSITELINK                Unlimited                  Unlimited

There is a no anti-virus on the server either that could be interfering, I am out of ideas at this point :(

EDIT 1

After running BPA, it gives and error:

Exchange Organization: Check whether the incoming message(CN=MyDomain,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=WG,DC=local) size isn't set
The maximum incoming message size isn't set in organization 'CN=MyDomain,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=WG,DC=local'. This can cause reliability problems.

Here are the sizes as of now:

[PS] C:\Temp>Get-TransportConfig | ft MaxSendSize, MaxReceiveSize

MaxSendSize                                                 MaxReceiveSize
-----------                                                 --------------
Unlimited                                                   Unlimited


[PS] C:\Temp>Get-ReceiveConnector | ft name, MaxMessageSize

Name                                                        MaxMessageSize
----                                                        --------------
Default EXCHSRVR                                            100 MB (104,857,600 bytes)
Client Proxy EXCHSRVR                                       100 MB (104,857,600 bytes)
Default Frontend EXCHSRVR                                   100 MB (104,857,600 bytes)
Outbound Proxy Frontend EXCHSRVR                            100 MB (104,857,600 bytes)
Client Frontend EXCHSRVR                                    100 MB (104,857,600 bytes)
ExchangeRelay                                               100 MB (104,857,600 bytes)

Again, smaller emails come through just fine. Seems like there is a 10mb receive limit somewhere that I cannot find.

share|improve this question
2  
Have you examined connectivity logs on firewall/router? –  Vick Vega May 13 at 22:33

3 Answers 3

Have you also liftet the organizational limits?

See this for reference:

Maximum size for messages received
Cmdlet: Set-TransportConfig

Parameter: MaxReceiveSize Mail flow > Receive connectors > More options More Options Icon > Organization transport settings > Limits tab > Maximum receive message size

Also, "connection reset by peer" points more to a networking problem than a size-limit-problem.

share|improve this answer
    
This site is set to 100mb send/receive, smaller emails come through just fine though but only the big ones stop. –  KPS May 14 at 17:32

All connectors where configured correctly, allowing attachments with a size of 10+mb. Emails where not being delivered due to our third party spam filter, AppRiver.

Per there support, they allow attachments with a size of 35mb. Per our tests, this is not true.

Once I bypassed the spam filter, emails of all shapes/sizes delivered successfully.

share|improve this answer

Try to add your server's IP address to the allowed list of relay connectors.

share|improve this answer
1  
Is there a reason that this solution would solve a problem that only affects emails with large attachments? –  Ladadadada May 29 at 8:26

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.