Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

i'm using Exchange 365 Cloud Mail Services and a Apple Server 10.9.1 (Mavericks). Now i would like to connect my Apple Servers Postfix to an Exchange SMTP Relay (Get notifications when Wiki is updated and other fancy things). The problem is that the Exchange doesn't allow to configure a SMTP Relay for Domains with a Dynamic IP(in my case the appleserver.local) . Is there any other solution to realize that? My Postfix should only send E-Mails to internal E-Mail Adresses.

Any help is welcome!

Error Log of Postfix

postfix/postmap[17226]: fatal: open database /Library/Server/Mail/Config/postfix/sasl_passwd.db: Permission denied
    May 14 18:50:58 appleserver.local postfix/pickup[14110]: 05635D9A12: uid=94 from=<noreply@192.168.2.100>
    May 14 18:50:58 appleserver.local postfix/cleanup[14875]: 05635D9A12: message-id=<53739ef145971_fdf3fd8244280d886649@appleserver.local.mail>
    May 14 18:50:58 appleserver.local postfix/qmgr[14111]: 05635D9A12: from=<noreply@192.168.2.100>, size=382120, nrcpt=1 (queue active)
    May 14 18:50:58 appleserver.local postfix/smtpd[14881]: connect from localhost[127.0.0.1]
    May 14 18:50:58 appleserver.local postfix/smtpd[14881]: warning: Illegal address syntax from localhost[127.0.0.1] in MAIL command: <noreply@192.168.2.100>
    May 14 18:50:58 appleserver.local postfix/smtp[14879]: 05635D9A12: to=<info@example.com>, relay=127.0.0.1[127.0.0.1]:10024, delay=0.98, delays=0.09/0.03/0.01/0.86, dsn=5.1.7, status=bounced (host 127.0.0.1[127.0.0.1] said: 501 5.1.7 id=13401-01 - Rejected by next-hop MTA on relaying, from MTA(smtp:[127.0.0.1]:10025): 501 5.1.7 Bad sender address syntax (in reply to end of DATA command))
    May 14 18:50:58 appleserver.local postfix/cleanup[14875]: F1CBBD9A32: message-id=<20140514165058.F1CBBD9A32@appleserver.local>
    May 14 18:50:58 appleserver.local postfix/qmgr[14111]: F1CBBD9A32: from=<>, size=2567, nrcpt=1 (queue active)
    May 14 18:50:58 appleserver.local postfix/bounce[14882]: 05635D9A12: sender non-delivery notification: F1CBBD9A32
    May 14 18:50:58 appleserver.local postfix/qmgr[14111]: 05635D9A12: removed
    May 14 18:50:59 appleserver.local postfix/error[14883]: F1CBBD9A32: to=<noreply@192.168.2.100>, relay=none, delay=0.02, delays=0/0.01/0/0, dsn=5.1.3, status=bounced (bad address syntax)
share|improve this question

1 Answer 1

Which KB article are you following? There's one for relaying from an internal "app server" if all you are going to email is internal O365 users: http://technet.microsoft.com/en-us/library/dn554323%28v=exchg.150%29.aspx

Use the "Direct Send" method.

Another alternative, the one I typically implement, is to deploy hMailServer (google it, it's free) on an internal Windows server. Then I setup the SMTP relay on it to email through Office 365.

But again, if you are only wanting to send emails to internal email addresses hosted on O365, then the Direct Send method works great and won't require any relay setup. Just email out with the source FROM address being an actual @yourdomain.com address and it will work just fine...but you might have to add your mail server's external IP or IP range if dynamic to the accepted IP's list so that it doesn't classify the email as spam (in the O365 admin Exchange portal)

share|improve this answer
    
i saw the KB Article, but didn't thougt about to use "Direct Send". Where do i have to set these settings? In the postfix config or in my php Wiki files(in this case Apple Wiki). –  DjangoUnchained May 14 at 15:49
    
You would setup postfix, that'd be the easiest. See here for more info: serverfault.com/questions/379013/… - let your apps on the Apple server send through postfix and set the FROM address to a mailbox on O365. That way no authentication is required. That link I showed is about a full relay but read the "answer" about certain versions. –  TheCleaner May 14 at 15:56
    
i run with postfix latest 2.9.1. I followed your link but i get the error above –  DjangoUnchained May 14 at 19:44

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.