Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

My provider has a (stupid) setup where the IP address for the gateway is on a totally different IP range than the assigned IP address. They insist on doing this for whatever reason. I'm trying to get Windows Server 2012 R2 configured using a static route but have had no luck. I was able to get the network configured on FreeBSD using the following configuration in /etc/rc.conf:

ifconfig_vtnet0="inet 142.4.196.xxx netmask 0xffffffff"
static_routes="net1 net2"
route_net1="-net 192.99.16.254/32 -iface vtnet0"
route_net2="default 192.99.16.254"

Is there anyway to convert this so it will work on Windows Server 2012 R2? I've tried doing route ADD 0.0.0.0 MASK 0.0.0.0 192.99.16.254 but no luck.

Here's my IP address info:

IP Address: 142.4.196.xxx
(Required) subnet mask: 255.255.255.255
Gateway: 192.99.16.254
share|improve this question
    
My provider has a (stupid) setup where the IP address is totally different than the assigned IP address. - That statement makes no sense. Can you clarify? –  joeqwerty May 14 at 18:20
    
Sorry, I meant My provider has a (stupid) setup where the IP address for the gateway is on a totally different IP range than the assigned IP address. –  ub3rst4r May 14 at 18:33
    
Your netmask should be 0.0.0.0 and not 255.255.255.255 for you to be able to reach the route. –  edvinas.me May 14 at 18:39

3 Answers 3

up vote 1 down vote accepted

OVH hosting does this same thing. the ip block you are assigned does not contain your gateway.

they provide per OS directions which perhaps can help you: http://help.ovh.co.uk/BridgeClient

your default route in your post will work, but you must provide a route to that gateway

share|improve this answer
    
My provider uses OVH and they referred me to a similar article (help.ovh.com/IpAlias) but there is no IP failover address provided. –  ub3rst4r May 14 at 19:28

You should not need to setup a static route, setting right netmask should be enough. You seem to have it set to 255.255.255.255, but you need to set it to 0.0.0.0

share|improve this answer
    
According to my provider, the netmask MUST be set to 255.255.255.255 otherwise OVH will block the IP address. Also, Windows Server 2012 R2 won't let me specify the net mask as 0.0.0.0 –  ub3rst4r May 14 at 19:29

After finally getting a hold of my provider, it turned out the problem was that the MAC address was wrong and thus causing it to not connect. I didn't have to add any static routes or anything to get to work (luckily).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.