Sign up ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

When I logon to Windows 2008 via the console or via RDP it shows me the names of user accounts already created as clickable buttons.

How do I prevent this and make Windows 2008 ask me for a username that must be typed?

share|improve this question

2 Answers 2

up vote 7 down vote accepted

You should be able to set this in the group policy editor (Run: gpedit.msc) under:

Computer Configuration > Policies > Administrative Templates > System > Logon

Set it to use the classic login screen. This will work if the server is standalone. If it is part of a domain, it will follow this policy as set by the domain policy instead.

share|improve this answer
Thanks Justin, worked a treat. –  Kev Aug 27 '09 at 15:07

Assuming that the server is standalone and not a member of a domain, then you can achieve the result you desire by performing any of the 3 options below:

  1. Enable the Interactive logon: Do not display last user name: setting in the Local Security Policy snap-in (secpol.msc).

  2. Change the registry value dontdisplaylastusername to 1 for the following key:


  3. Run the following PowerShell command:

    Set-ItemProperty -Path "HKLM:Software\Microsoft\Windows\CurrentVersion\Policies\System" -Name dontdisplaylastusername -Value 1 -Type DWORD

All steps above are detailed here. Please note that the link is a post on my blog.

If the server is a member of a domain enable the same policy in a GPO (Group Policy Object) and apply it to the relevant server(s) then run gpupdate /force on the relevant server(s) or reboot them to effect the change.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.