Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I am trying to set up a pfSense server with OpenVPN.

The OpenVPN will use the tap interface, tun clients are no option for us.

The LAN network is 10.0.0.0/24, the pfSense machine is 10.0.0.10 and clients DHCP range is currently 10.0.0.200-10.0.0.220.

The clients connect just fine with DHCP and can use the network.

I have tried to assign static IPs with the client specific overrides in pfSense. I used the commonly advised ifconfig-push command, but the clients I tested with(Windows 8 and Arch Linux) just don't take the IP assigned in their respective override. I've tried ifconfig-push with different arguments(client-IP + server, client-IP + subnet mask, ..).

If I leave the DHCP for the tap-interface on, clients will take an IP address from the client DHCP range, if I switch DHCP off clients don't get an IP at all. I have tried to push the static IP inside and outside of the DHCP range.

Is there any way to make the override work and force the assigned IP to the client? I would need this especially for access limitations with pfSense's firewall.

share|improve this question

1 Answer 1

up vote 1 down vote accepted

After some deep digging I found a bug in pfSense's Redmine tracker. This states that the OpenVPN server is missing the client-config-dir variable.

Adding

mode server;client-config-dir /var/etc/openvpn-csc;

to the advanced server options as well as providing the client specific override

ifconfig-push [IP] [netmask]

did the trick.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.