Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am trying to set up a Samba share on a Centos machine. I want to connect to this server using smbclient on OS X. Here is what happens:

> smbclient -L X.X.X.X
timeout connecting to X.X.X.X:445
timeout connecting to X.X.X.X:139
Error connecting to X.X.X.X (Operation already in progress)
Connection to X.X.X.X failed

What could be going wrong? Here is my iptables dump on the Centos machine (the server):

> iptables -L -n
Chain INPUT (policy ACCEPT)
target     prot opt source               destination         
ACCEPT     all  --  0.0.0.0/0            0.0.0.0/0           
REJECT     all  --  0.0.0.0/0            127.0.0.0/8         reject-with icmp-port-unreachable 
ACCEPT     all  --  0.0.0.0/0            0.0.0.0/0           state RELATED,ESTABLISHED 
ACCEPT     tcp  --  0.0.0.0/0            0.0.0.0/0           tcp dpt:445 
ACCEPT     tcp  --  0.0.0.0/0            0.0.0.0/0           tcp dpt:3000 
ACCEPT     tcp  --  0.0.0.0/0            0.0.0.0/0           tcp dpt:80 
ACCEPT     tcp  --  0.0.0.0/0            0.0.0.0/0           tcp dpt:443 
ACCEPT     tcp  --  0.0.0.0/0            0.0.0.0/0           state NEW tcp dpt:22 
ACCEPT     icmp --  0.0.0.0/0            0.0.0.0/0           icmp type 8 
REJECT     all  --  0.0.0.0/0            0.0.0.0/0           reject-with icmp-port-unreachable 
ACCEPT     tcp  --  0.0.0.0/0            0.0.0.0/0           tcp dpt:3000

And finally, my smb.conf:

[global]
workgroup = workgroup
security = SHARE
load printers = No
default service = global
path = /home
available = No
encrypt passwords = yes

[share]
writeable = yes
admin users = myusername
path = /home/myhome/
force user = root
valid users = myusername
public = yes
available = yes
share|improve this question
    
Do the samba logs provide any insight? /var/log/samba/log.smdb and /var/log/samba/log.clientName –  Mark Aug 27 '09 at 22:09
    
Oh, you might have to turn on the logs in [global] "log file = /path/to/log/log.%m" creates a log for each client –  Mark Aug 27 '09 at 22:11
add comment

1 Answer

You could try flushing the iptable rules to test if it works when there are no rules present:

iptables -F

This might narrow your search down a little or maybe even fix your problem.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.