Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

tried to install squid with command

yum install squid

and it consistently hangs on

Running Transaction
 Installing: squid                        #####################     [1/1]

Had no problems with hundreds of other packages. Does anyone have an idea on what could be the problem?

edit: tried both: yum clean all + changing mirror, and rebuild rpm, doesn't help.

Thanks.

share|improve this question
add comment

2 Answers

I wonder if you have a corrupted package. I suggest running yum clean all and start again. You probably will get a different mirror and a fresh download.

share|improve this answer
add comment

I would try Keith's suggestion of "yum clean all" first. If that doesn't work, I have encountered a situation like this when there is actually an issue with the RPM database.

You can try to rebuild the RPM database by doing:

sudo rm -f /var/lib/rpm/__db.* (you could move them to a temporary directory to be cautious)

sudo /bin/rpm --rebuilddb

After that completes, try the "yum install squid" again.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.