Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm trying to start apache2 server but it complains at phpmyadmin.conf

enter image description here

File phpmyadmin.conf looks so:

enter image description here

It looks ok for me, but perhaps I miss something.

This error appeared after I tried to change default location of website doing commands as a2dissite,a2ensite. My apache.conf file looks so http://paste.org.ru/?ingbp6

Help! Thanks.

share|improve this question
    
Does PHP work elsewhere? Can you get a phpinfo() printed out from any page? –  Nathan C May 23 at 17:17
    
yes, fortunately or unfortunately it works - paste.org.ru/?ec2097 –  gekannt May 23 at 17:26

1 Answer 1

up vote 1 down vote accepted

This is due to apache-php module missing or being turned off. Try this:

aptitude install libapache2-mod-php5
cd /etc/apache2/mods-enabled/
ln -s ../mods-available/php5.conf ./php5.conf
ln -s ../mods-available/php5.load ./php5.load
/etc/init.d/apache2 restart
share|improve this answer
    
thanks for advice! I did it paste.org.ru/?6u5dcx and got a new error... secure.conf file looks so paste.org.ru/?7xzjwh –  gekannt May 23 at 17:44
    
Comment the line out like this: #Action php-cgi /php-bin/php –  edvinas.me May 23 at 17:51
    
helped! it works! thanks. Is it not bad just to comment this line? –  gekannt May 23 at 17:52
1  
The line does not work due to another mod_action plugin being disabled. You can enable the line once you have mod_action enabled. –  edvinas.me May 23 at 17:54
    
Also, please accept the answer if it solved your issue. –  edvinas.me May 23 at 17:56

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.