Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've hosted a copy of SQL Server 2008 Express on my machine, and i have a tool that can connect to and query SQL databases (LINQPad, i'm using it to do testing and initial table setup). What do i tell it to connect to?

(Note: i'm just learning SQL, hope this is the right question... Please don't hesitate to tell me if i'm doing something wrong)

share|improve this question
    
If it helps, the tool already shows a connection to .\SQLEXPRESS... can anyone tell im a bit lost? –  RCIX Aug 28 '09 at 2:37
    
Hi RCIX, SQL Server can be a bit confusing, especially if you come from a non-SQL background. Don't stress though, it's not that hard once you get the hang of it. –  Mark Henderson Aug 28 '09 at 3:12
    
You will also find a lot of people over on Stack Overflow will be knowledgeable on programming stuff for SQL (but probably not the setup of it). –  Mark Henderson Aug 28 '09 at 3:13
add comment

2 Answers

up vote 1 down vote accepted

After you have enabled TCP/IP (see Chage's answer), you will need to connect to your SQL Server Instance.

When you were installing it, it may have asked if you if you wanted to install it as a "Default Instance" or a "Named Instance".

Chances are, if it's SQL Express it's a named instance, and the default instance name is "SQLEXPRESS".

The way to connect to it, is to specify the server name as SERVER\INSTANCE, so in your case, "localhost\SQLEXPRESS". If you are using the "Default" instance, you just use the server name (drop the \INSTANCE) part.

The connection you are seeing to .\SQLEXPRESS is the connection to your instance. If you are using Integrated Authentication (it should also have asked you this during installation), then you will need to give the account that LINQPad is runing under permissions. This is another question alltogether ;) If you're running LINQPad under your current user then you should be OK.

share|improve this answer
    
I'm not exactly sure how it got installed... When i ran the Web Platform Installer, it was already installed. Thanks! –  RCIX Aug 28 '09 at 3:12
    
Ah, in that case it's using the Named Instance \SQLEXPRESS with integrated authentication and the default collations, in which case the above instructions should be fine. Enjoy! –  Mark Henderson Aug 28 '09 at 3:14
add comment

By default, TCP Settings will probably be disabled. You will need to open the SQL Server Configuration manager and Enable TCP Connections

At this point, in theory the SQL Server will be listening on port 2775

share|improve this answer
    
The default instance listens on port 1433 by default. Named instances will pull a port number dynamically. –  mrdenny Aug 28 '09 at 2:46
    
so i killed the sqlsrvr and sqlwriter process and i'm starting to get the idea that that wasn't the right thing to do... Now what? :) –  RCIX Aug 28 '09 at 2:49
    
i mean after enabling TCP/IP. –  RCIX Aug 28 '09 at 2:49
    
Fixed that, now what should i do? i have the TCP/IP setting enabled. –  RCIX Aug 28 '09 at 3:04
    
All you need to do now is start the MSSQL$SQLExpress service. –  mrdenny Aug 28 '09 at 4:12
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.