Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have googled for days before asking and I feel like I have tried everything but ntp is still not updating the time of the system automatically. I have left it running for days and still I get the following output:

[root@server1 etc]# ntpq -p
     remote           refid      st t when poll reach   delay   offset  jitter
==============================================================================
 ntp1.flashdance .INIT.          16 u    -   64    0    0.000    0.000   0.000
 ntp.jine.se     .INIT.          16 u    -   64    0    0.000    0.000   0.000
 ntp2.flashdance .INIT.          16 u    -   64    0    0.000    0.000   0.000
 timehost.lysato .INIT.          16 u    -   64    0    0.000    0.000   0.000

[root@server1 etc]# ntpdate -d 0.se.pool.ntp.org
24 May 21:24:58 ntpdate[62896]: ntpdate 4.2.6p5@1.2349-o Sat Nov 23 18:21:48 UTC 2013 (1)
Looking for host 0.se.pool.ntp.org and service ntp
host found : timehost.lysator.liu.se
transmit(130.236.254.17)
receive(130.236.254.17)
transmit(130.236.254.17)
receive(130.236.254.17)
transmit(130.236.254.17)
receive(130.236.254.17)
24 May 21:24:58 ntpdate[62896]: 130.236.254.17 rate limit response from server.
transmit(193.228.143.12)
receive(193.228.143.12)
transmit(193.228.143.12)
receive(193.228.143.12)
transmit(193.228.143.12)
receive(193.228.143.12)
transmit(193.228.143.12)
receive(193.228.143.12)
transmit(79.136.84.63)
receive(79.136.84.63)
transmit(79.136.84.63)
receive(79.136.84.63)
transmit(79.136.84.63)
receive(79.136.84.63)
transmit(79.136.84.63)
receive(79.136.84.63)
transmit(46.22.115.26)
receive(46.22.115.26)
transmit(46.22.115.26)
receive(46.22.115.26)
transmit(46.22.115.26)
receive(46.22.115.26)
transmit(46.22.115.26)
receive(46.22.115.26)
server 130.236.254.17, port 123
stratum 1, precision -20, leap 00, trust 000
refid [GPS], delay 0.02982, dispersion 24.00003
transmitted 3, in filter 2
reference time:    d72b6e22.09959634  Sat, May 24 2014 21:14:42.037
originate timestamp: d72b6e40.b3585db2  Sat, May 24 2014 21:15:12.700
transmit timestamp:  d72b708a.e7533f64  Sat, May 24 2014 21:24:58.903
filter delay:  0.02994  0.02982  0.00000  0.00000 
         0.00000  0.00000  0.00000  0.00000 
filter offset: -586.200 -586.200 0.000000 0.000000
         0.000000 0.000000 0.000000 0.000000
delay 0.02982, dispersion 24.00003
offset -586.200926

server 193.228.143.12, port 123
stratum 2, precision -23, leap 00, trust 000
refid [193.228.143.12], delay 0.03706, dispersion 0.00000
transmitted 4, in filter 4
reference time:    d72b6d43.23c9c958  Sat, May 24 2014 21:10:59.139
originate timestamp: d72b6e40.f07db8a7  Sat, May 24 2014 21:15:12.939
transmit timestamp:  d72b708b.211ebd04  Sat, May 24 2014 21:24:59.129
filter delay:  0.03706  0.03716  0.03712  0.03714 
         0.00000  0.00000  0.00000  0.00000 
filter offset: -586.195 -586.195 -586.195 -586.195
         0.000000 0.000000 0.000000 0.000000
delay 0.03706, dispersion 0.00000
offset -586.195733

server 79.136.84.63, port 123
stratum 2, precision -21, leap 00, trust 000
refid [79.136.84.63], delay 0.04167, dispersion 0.00032
transmitted 4, in filter 4
reference time:    d72b6dfa.d84c236b  Sat, May 24 2014 21:14:02.844
originate timestamp: d72b6e41.271b1a96  Sat, May 24 2014 21:15:13.152
transmit timestamp:  d72b708b.582552e4  Sat, May 24 2014 21:24:59.344
filter delay:  0.04289  0.04172  0.04167  0.04463 
         0.00000  0.00000  0.00000  0.00000 
filter offset: -586.200 -586.199 -586.199 -586.201
         0.000000 0.000000 0.000000 0.000000
delay 0.04167, dispersion 0.00032
offset -586.199643

server 46.22.115.26, port 123
stratum 3, precision -20, leap 00, trust 000
refid [46.22.115.26], delay 0.02687, dispersion 0.00003
transmitted 4, in filter 4
reference time:    d72b6781.8ac88413  Sat, May 24 2014 20:46:25.542
originate timestamp: d72b6e41.4c57134a  Sat, May 24 2014 21:15:13.298
transmit timestamp:  d72b708b.7fc9d467  Sat, May 24 2014 21:24:59.499
filter delay:  0.02699  0.02696  0.02687  0.02701 
         0.00000  0.00000  0.00000  0.00000 
filter offset: -586.201 -586.201 -586.201 -586.201
         0.000000 0.000000 0.000000 0.000000
delay 0.02687, dispersion 0.00003
offset -586.201891

24 May 21:24:59 ntpdate[62896]: step time server 130.236.254.17 offset -586.200926 sec

However I can force the update manually like so

[root@server1 etc]# ntpdate -uq se.pool.ntp.org
server 193.228.143.13, stratum 2, offset 0.006334, delay 0.04576
server 193.228.143.12, stratum 2, offset 0.005765, delay 0.03703
server 130.236.254.17, stratum 1, offset 0.000529, delay 0.02977
server 89.160.71.4, stratum 1, offset 0.000366, delay 0.02917
24 May 21:33:37 ntpdate[64428]: adjust time server 89.160.71.4 offset 0.000366 sec

Any ideas on what could be the problem?

Thanks!

Update

My ntp.conf

# For more information about this file, see the man pages
# ntp.conf(5), ntp_acc(5), ntp_auth(5), ntp_clock(5), ntp_misc(5), ntp_mon(5).

driftfile /var/lib/ntp/drift

# Permit time synchronization with our time source, but do not
# permit the source to query or modify the service on this system.
restrict default kod nomodify notrap nopeer noquery
restrict -6 default kod nomodify notrap nopeer noquery

# Permit all access over the loopback interface.  This could
# be tightened as well, but to do so would effect some of
# the administrative functions.
restrict 127.0.0.1
restrict -6 ::1

# Hosts on local network are less restricted.
#restrict 192.168.1.0 mask 255.255.255.0 nomodify notrap

# Use public servers from the pool.ntp.org project.
# Please consider joining the pool (http://www.pool.ntp.org/join.html).
server 0.se.pool.ntp.org iburst
server 1.se.pool.ntp.org iburst
server 2.se.pool.ntp.org iburst
server 3.se.pool.ntp.org iburst

#broadcast 192.168.1.255 autokey        # broadcast server
#broadcastclient                        # broadcast client
#broadcast 224.0.1.1 autokey            # multicast server
#multicastclient 224.0.1.1              # multicast client
#manycastserver 239.255.254.254         # manycast server
#manycastclient 239.255.254.254 autokey # manycast client

# Enable public key cryptography.
#crypto

includefile /etc/ntp/crypto/pw

# Key file containing the keys and key identifiers used when operating
# with symmetric key cryptography.
keys /etc/ntp/keys

# Specify the key identifiers which are trusted.
#trustedkey 4 8 42

# Specify the key identifier to use with the ntpdc utility.
#requestkey 8

# Specify the key identifier to use with the ntpq utility.
#controlkey 8

# Enable writing of statistics records.
#statistics clockstats cryptostats loopstats peerstats
share|improve this question
    
Your first log shows that it successfully adjusted the clock. What exactly is happening? –  Michael Hampton May 24 at 19:45
    
It only seems to update when I do ntpdate -uq manually. If I let it run for a month or two it will be 600 seconds off for example as shown above –  UberBrainChild May 24 at 20:11
1  
It is not clear if you are running ntpd or ntpdate from a cron job. If you are using ntpd you need to post your ntp.conf in order to give us an idea how ntpd is set up. If it is ntpdate from a cron job please give the ntpdate invocation from the cron job –  dfc May 24 at 21:59
    
I have not configured any cron job, do I have to do that for ntp to work? And I have udated my question with the configuration –  UberBrainChild May 26 at 16:27
    
Are there relevant messages in your logs. Don't forget to check /var/log/audit/audit.log too –  Iain May 26 at 16:53

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.