Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I bought a years subscription at bluevm.com (found some coupon code, it was only about $15 for a whole year) to launch my first Rails Production server. I'm running Nginx with Unicorn and MySQL on Ubuntu 13.04. Once I got the initial server configuration setup the server will run when I run rails unicorn and point it to my config file and run it as a daemon process, but randomly when I go visit it the URL (I'm using cloudfare for DNS) I get a CentOS apache test page? This lead me to believe that it was something wrong with the VPS (since CentOS is what their using to host the VPS?), I can't find anything in production or nginx logs that would indicate a problem when I see this test page. Their support says the problem is on my end though?

Not sure where to go from here. Can't tell if it's just the cheap hosting that's causing my problem or what?

Server stats: 512MB ram 512MB swap 2GB/25GB hdd used 1TB bandwidth

The only thing I can think of is that I'm getting some sort of DDOS attack or something that's crashing the server?

I tried to setup ufw but don't know if it's actually working (wanted to block traffic on everything but 80 and 4321, which is the port ssh is running on)

When I notice that the server is showing the CentOS apache test page instead of the rails app, I get "connection refused" when I try to ssh into the VPS as well

I tried to find a concise guide on setting up a VPS for Rails 4 but can't find a complete comprehensive guide, AND I'm not sure if the problem DOES lie with me or the VPS

Any input would be greatly appreciated!

share|improve this question
    
Have the same problem as you, near exact same specs, using BlueVM also. I happen to be running Nginx with MySQL to run my wordpress. Can't go a day without getting the apache test page! –  chinnychinchin May 27 at 21:20
    
I seem to be getting a RSA Host Key changed ("man in the middle attack warning") whenever I try to SSH into the "apache test afflicted" machine. Upon reboot from my Feathur panel, this problem goes away as well... –  chinnychinchin May 28 at 0:56
    
I've come to the conclusion that Feathur keeps crashing thus rendering that CentOS apache test page. Their support is of no help, it's SUPER cheap hosting so I can't really be mad! –  SentraThis96 May 29 at 0:17
    
You have reason to be mad. I've also used UGVPS, which has since been acquired by ChicagoVPS, along the same pricing. Never had such a problem. I have tried fiddling with the Mysql and Nginx configs to see if the problem is I'm exceeding my memory at all. Will report on what I find. –  chinnychinchin May 29 at 18:02
    
Seems to be related to RAM usage. I lowered my MySQL and Nginx configurations to handle fewer connections, and it went several days without crashing. I suggest you play around with the respective conf files of the services you're using. –  chinnychinchin Jun 3 at 3:07

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.