Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm trying to install Lotus Notes 9.0.1 32 bit for Linux (IBM has not developed a 64 bit package yet) on a Debian 7.5 "wheezy" 64 bit but I'm running into some issues and would need your help.

There are many posts on the Internet dealing with the topic, but related to Ubuntu or Mint. I haven't been able to find anything consistent for Debian. None of the solutions that seems to work for Ubuntu or Mint has worked for me on Debian...

I have modified the initial deb package to remove any pre-dependencies and dependencies, repackaged it and successfully installed it. I've been able to see the Lotus Notes splash screen and to accept the licence from the terminal window but then, the client shut down. When I tried to start it from the command line, here is what it said:

/opt/ibm/notes$ ./notes
./notes: error while loading shared libraries: libgnomevfs-2.so.0: wrong ELF class: ELFCLASS64

My issue seeems to come from a 32 bit package that I haven't been able to install: libgnomevfs2-0:i386:

unknown@debian:/opt/ibm/notes$ dpkg -l | grep libgnomevfs2
ii  libgnomevfs2-0                        1:2.24.4-2                         amd64        GNOME Virtual File System (runtime libraries)
ii  libgnomevfs2-common                   1:2.24.4-2                         all          GNOME Virtual File System (common files)
ii  libgnomevfs2-extra                    1:2.24.4-2                         amd64        GNOME Virtual File System (extra modules)

But it seems not possible to install it:

unknown@debian:/opt/ibm/notes$ sudo apt-get install libgnomevfs2-0:i386
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation : 

Les paquets suivants contiennent des dépendances non satisfaites :
 libgnomevfs2-0:i386 : Dépend: libgnomevfs2-common:i386 (>= 1:2.24) mais il n'est pas installable
                       Dépend: libgnomevfs2-common:i386 (< 1:2.25) mais il n'est pas installable
                       Recommande: libgnomevfs2-extra:i386 mais ne sera pas installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».

Here is what I've tried so far:

But now, I don't know what to do.... If any of you has a positive feedback about successful installation or any idea, it would be great to share.

Many thanks in advance for your help.

Post note:

I have found a quick and dirty way to fix it by creating symlinks to the libraries into /opt/ibm/notes as follows:

$ cd /opt/ibm/notes
$ sudo ln -s /usr/lib32/libgnomevfs-2.so.0
$ sudo ln -s /usr/lib32/libgnome-2.so.0
$ sudo ln -s /usr/lib32/libgnomeui-2.so.0
$ sudo ln -s /usr/lib32/i386-linux-gnu/libavahi-glib.so.1
$ sudo ln -s /usr/lib32/libbonobo-2.so.0
$ sudo ln -s /usr/lib32/libbonobo-activation.so.4
$ sudo ln -s /usr/lib32/libbonoboui-2.so.0
$ sudo ln -s /usr/lib32/libgnomecanvas-2.so.0
$ sudo ln -s /usr/lib32/libORBit-2.so.0
$ sudo ln -s /usr/lib32/i386-linux-gnu/libgnome-keyring.so.0
$ sudo ln -s /usr/lib32/libORBitCosNaming-2.so.0
$ sudo ln -s /usr/lib32/i386-linux-gnu/pkcs11/gnome-keyring-pkcs11.so
$ ./notes
share|improve this question
    
After some researches, I figured out that libgnomevfs-2.so.0 was actually installed in /usr/lib32 but Lotus Notes is still trying to use the 64 bit version... –  Sebastien Damaye May 26 at 8:49
    

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.