Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm running Ubuntu 9.04.

I have an onboard network card. The computer usually boots perfectly, but today, I don't have an IP address. The light is on, on the network card as well as the switch. Other computers work in the switch and I tried other ports to no avail.

# sudo ifconfig eth0 up
SIOCSIFFFLAGS: Resource temporarily unavailable
# sudo dhclient
... some messages ...
receive_packet failed on eth0: Network is down

Driver is e100. I tried modprobe eepro100, but still same problem.

Update: Putting in another network card didn't help! Could it be some sort of IRQ conflict?

share|improve this question
1  
Are the the card's IP settings configured statically or dynamically (e.g. DHCP). If the latter, is the DHCP server up and configured and able to service the request from the client (e.g. spare IP addresses, MAC address table entry correct (if used) &c)? –  mas Aug 28 '09 at 9:38
    
lspci command should so your card's make and model –  RateControl Aug 28 '09 at 12:48
    
DHCP. And other computers on the network are getting IPs fine. dhclient won't even get the packets out since the interface can't come up. –  Paul Tarjan Aug 28 '09 at 18:23

3 Answers 3

up vote 4 down vote accepted

The first thing to try is to make sure you have link. You can check this using either

# ethtool eth0

or

# mii-tool eth0

Look for a line about Link Detected. If it says no, then you have a problem with your network card, network cable or switch.

I wrote a guide to troubleshooting network problems that you might find useful.

share|improve this answer
    
Link Detected : No. :(. Did something die in the motherboard to-do with networking? –  Paul Tarjan Aug 28 '09 at 6:07
    
Wouldn't be the first time. Disable the onboard card and plug in another one. –  John Gardeniers Aug 28 '09 at 11:22
1  
I'd check the network cable works in another computer and check that the network port works with another cable and computer. This should rule out either of those. As John suggests, try a new network card. –  David Pashley Aug 28 '09 at 17:59

have you tried a different network cable?

share|improve this answer

Set a static ip adress in /etc/network/interfaces

Something like this, change it to your network config

# The primary network interface
auto eth0
iface eth0 inet static
        address 192.168.0.100
        netmask 255.255.255.0
        network 192.168.0.0
        broadcast 192.168.0.255
        gateway 192.168.0.5

Then reboot router or other end of your network (computer - router/modem).

Now see what happens. Of still no succes, see if you can set iface eth0 inet DHCP instead of the above...

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.